Jump to content

  • Log In with Google      Sign In   
  • Create Account


Adding Boost 1.53.0 to Code::Blocks


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
3 replies to this topic

#1 handoman   Members   -  Reputation: 219

Like
0Likes
Like

Posted 09 February 2013 - 08:58 PM

I've been trying to get boost libraries to work with code::blocks(mingw), but I can't seem to get it right. I have followed the instructions on official website:

http://www.boost.org/doc/libs/1_53_0/more/getting_started/windows.html#link-your-program-to-a-boost-library

 

I built the libs and everything and added the include and lib to my compiler search directory... but what do i do next? when I write #include <boost... nothing comes up. I copied the test code, and it failed saying :fatal error: boost/lambda/lambda.hpp: No such file or directory. 

 

any help?


Edited by handoman, 09 February 2013 - 08:59 PM.


Sponsor:

#2 handoman   Members   -  Reputation: 219

Like
0Likes
Like

Posted 10 February 2013 - 12:34 AM

ugh, so I think I got it to work, but not how it says to do it. I had to copy the include files into mingw's include folder, instead of linking it through compiler settings. It's pretty stupid, I don't understand I why It wouldnt work when putting the file locations in the search directory...



#3 handoman   Members   -  Reputation: 219

Like
0Likes
Like

Posted 10 February 2013 - 12:56 AM

okay I guess its not working... I keep getting: undefined reference to `boost::chrono::steady_clock::now()'

I don't understand...I don't have to link the chrono file do I?



#4 BitMaster   Crossbones+   -  Reputation: 3882

Like
0Likes
Like

Posted 12 February 2013 - 04:26 AM

You should not have to copy the Boost headers into the MinGW include folder. Whenever you think you have to modify your compiler's include folder for any reason, you are almost certainly doing something very wrong.

Boost has always been working fine for me with the Code::Blocks/MinGW combo, although in my case I use automatically generated project files via CMake.
Without CMake, you will have to specify additional include folders somewhere in the build system. If that does not work you should search for the problem with that (Is it the right option? Is it the right directory? Is that only the option that is applied to new projects, not existing ones? etc).
Also, while a lot of Boost libraries are header only, several of them require to link to libraries. Usually Boost is able to link itself (you still need to specify the library path somewhere in the build system though), but in your case the auto-linking does not appear to work. I don't use autolinking in my setup, so you would have to look into the documentation why it does not work and how to turn it on or alternative just link the library manually. Without CMake I would not do it manually though.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS