Jump to content

  • Log In with Google      Sign In   
  • Create Account

GLFW Linker error (VS 2010)


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
2 replies to this topic

#1 Somber   Members   -  Reputation: 300

Like
0Likes
Like

Posted 27 February 2013 - 12:32 PM

Hello everyone, I'm pretty inexperienced in C++, and entirely new to these forums, so please excuse me if the solution to my problem seems obvious.

 

I started on the open.gl tutorials yesterday, but was immediately halted in my tracks by what seems like it should be a trivial issue when I tried to compile the first example program (Using GLFW). The IDE kept giving me these errors:

1>main.obj : error LNK2019: unresolved external symbol _glfwTerminate referenced in function _main
1>main.obj : error LNK2019: unresolved external symbol _glfwSleep referenced in function _main
1>main.obj : error LNK2019: unresolved external symbol _glfwInit referenced in function _main

 

I took that to mean that I'd made some mistake when I set the dependency directory settings in VS; but no matter which folder I pointed it to, the compiler couldn't find the library, so I'm starting to wonder if I'm doing something else wrong (would be quite a feat, I haven't written a single line of code myself yet...). 

 

 

In case I was right in my initial assumption, here are the things I changed in the project settings (Only changed these for debugging mode):

Configuration Properties -> C/C++->Code Generation -> Runtime library -> Multithreaded Debug DLL

Configuration Properties-> C/C++->General->Additional Include directories-> C:\SomeDirectoryPath\GLFW Binary Files\glfw-2.7.7.bin.WIN64\include

Configuration Properties->Linker->General->Additional library directories->C:\SomeDirectoryPath\GLFW Binary Files\glfw-2.7.7.bin.WIN64\lib-msvc110

Configuration Properties->Linker->Input->Additional dependencies->"glfw.lib"

Everything else should be according to project defaults.

 

The code I'm trying to compile and run (straight from the tutorial):

 

#include <GL/glfw.h>
int main()
{
    glfwInit();
    glfwSleep( 1.0 );
    glfwTerminate();
}

gl.h,glu.h, and glfw.h seem to have been added automatically by the IDE under external dependecies, other than that, there are no header files in the project.

 

I'd be grateful if anyone could give me any suggestions as to what might be the issue.


Edited by Somber, 27 February 2013 - 12:33 PM.


Sponsor:

#2 Serapth   Crossbones+   -  Reputation: 5485

Like
2Likes
Like

Posted 27 February 2013 - 03:54 PM

It looks like you haven't linked to the libraries properly.  You can either learn about linking libraries in C++ or add the following lines to the cpp file containing main() 

 

#pragma comment(lib, "GLFW.lib")
#pragma comment(lib, "opengl32.lib")
#pragma comment(lib, "glu32.lib")

 

Make sure that glfw.dll is in the same directory as your generated exe.

 

 

In C++ when linking, you need to properly match libraries to libraries.  For example, 64bit to 64bit, or debug to debug, multithreaded to mutlithreaded, etc...  Meaning for example if you are compiling a 64 bit dynamically linked debug build, you need to link against a 64bit dynamically linked debug library. If it sounds like a right pain in the ass, it is. 


Edited by Serapth, 27 February 2013 - 03:56 PM.


#3 Somber   Members   -  Reputation: 300

Like
0Likes
Like

Posted 27 February 2013 - 05:51 PM

All right, got it compiling at last. It seems that Serapth was right, and I was using an incompatible library file (was compiling for 32 bit while using the 64 bit version). I got a couple of LNK2005 errors after downloading and linking to the correct one, which was solved by changing the runtime library option back to Multi-threaded DLL (had been mucking about with diffrent properties). Didn't use the

 

 

 

#pragma comment(lib, "GLFW.lib")
#pragma comment(lib, "opengl32.lib")
#pragma comment(lib, "glu32.lib")
 

code, and the executable doesn't seem to care wether the DLL file is there or not.

 

Thanks alot Serapth happy.png






Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS