Jump to content

  • Log In with Google      Sign In   
  • Create Account

global function or static function ?


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
10 replies to this topic

#1 Alundra   Members   -  Reputation: 868

Like
0Likes
Like

Posted 28 February 2013 - 09:57 PM

Hi all,

A design question is with us tonight, I would like to have your opinion.

Imagine a class Vector2,Vector3,Vector4, all of them has a global function to compute the dot product :

 

 

VectorN VectorDot( const VectorN& A, const VectorN& B );
N is 2, 3 and 4.
 

What is the best design, Make it global in the namespace or static for each class ?

 

 

First option :
Namespace::VectorDot( a, b );
Second option :
Namespace::Vector2::Dot( a, b );
 

Same for math function (abs,clamp,sqrt...), global or static in a Math class ?

I was a big user of global function and I have changed to static into a class recently, it's just a design question but it's nice to have differents opinion with experience of each.I have changed because the class can be seen like a scope.

 

Thanks



Sponsor:

#2 Trienco   Crossbones+   -  Reputation: 2194

Like
0Likes
Like

Posted 28 February 2013 - 11:03 PM

Based on the simple rule "prefer non-friend non-member functions" the obvious answer would be "global" (though technically the static function is just as global with a more annoyingly fiddly scope).

 

Resist the temptation to stuff everything into classes. You want to able to extend your code without touching existing code, which is a lot easier if the functions working with/on your objects are completely independent (and don't need to access private members).


f@dzhttp://festini.device-zero.de

#3 frob   Moderators   -  Reputation: 21434

Like
0Likes
Like

Posted 28 February 2013 - 11:14 PM

Both, except the member function shouldn't be static.

Have a member function (non-static) and a non-member function.

Have one of them call the other. Most likely you'll want the member function to call the global function.


For the math stuff...
Having a bunch of static member function vs a function in a namespace are essentially identical. I prefer a bunch of math functions in a namespace like MathUtil::Somefunc();
Check out my personal indie blog at bryanwagstaff.com.

#4 EWClay   Members   -  Reputation: 659

Like
0Likes
Like

Posted 01 March 2013 - 02:31 AM

In maths libraries you often have operations between different types. If you use static functions it's not clear which class they should belong to.

It's more consistent therefore to have all functions as non-member functions in the namespace. Also you get argument dependent lookup and can overload operators.

#5 Alundra   Members   -  Reputation: 868

Like
1Likes
Like

Posted 01 March 2013 - 06:42 AM

You can have a look at Doom3 BFG math source code who use a class to store static function :

https://github.com/id-Software/DOOM-3-BFG/blob/master/neo/idlib/math/Math.h

line 315



#6 phil_t   Crossbones+   -  Reputation: 3928

Like
2Likes
Like

Posted 01 March 2013 - 01:46 PM

Given that the dot operation is completely specific to the type on which it's operating (i.e. you'd need to write different code for dot for Vector2, Vector3, Vector4, etc....), it's not generic at all, and so I would have a slight preference to put it as a static method on the class itself. This is in contrast to something like std::sort, which is one piece of code that works on many types and makes sense to be global.


Edited by phil_t, 01 March 2013 - 01:50 PM.


#7 frob   Moderators   -  Reputation: 21434

Like
0Likes
Like

Posted 01 March 2013 - 02:15 PM

Given that the dot operation is completely specific to the type on which it's operating (i.e. you'd need to write different code for dot for Vector2, Vector3, Vector4, etc....), it's not generic at all, and so I would have a slight preference to put it as a static method on the class itself. This is in contrast to something like std::sort, which is one piece of code that works on many types and makes sense to be global.

 
Not generic in that it should be made into a template.
 
From my experience it is best to provide two signatures:
 


class Vector3{
...
float Dot( const Vector3 &lhs) const { return DotProduct(this,lhs); }
};

 

float DotProduct(const Vector3 &rhs, const Vector3 &lhs) {...}

 

The same with CrossProduct and other assorted vector/matrix operations.


Edited by frob, 01 March 2013 - 02:15 PM.

Check out my personal indie blog at bryanwagstaff.com.

#8 ApochPiQ   Moderators   -  Reputation: 15815

Like
1Likes
Like

Posted 01 March 2013 - 02:37 PM

One function, in a namespace, with overloads for each type.

#9 mhagain   Crossbones+   -  Reputation: 8000

Like
0Likes
Like

Posted 01 March 2013 - 03:44 PM

Personally I prefer to be more specific; i.e. instead of writing a set of overloaded "Dot" functions I'll write "Vector2Dot", "Vector3Dot", "Vector4Dot" (as standalone functions rather than class members) - the reason why is the old chestnut of "reading code is harder than writing it", and this way it's absolutely explicit what types are being operated on.  The extra verbosity is something I accept as a fair tradeoff.


It appears that the gentleman thought C++ was extremely difficult and he was overjoyed that the machine was absorbing it; he understood that good C++ is difficult but the best C++ is well-nigh unintelligible.


#10 ApochPiQ   Moderators   -  Reputation: 15815

Like
2Likes
Like

Posted 01 March 2013 - 08:11 PM

In that case, why stop at function names? Why not just do full systems Hungarian everywhere? Then you never have any doubt.

 

 

(BTW, I don't buy that argument, if it wasn't obvious. A dot product is a dot product. The types it operates on are obvious already: vectors. How many components each vector has is up for debate, but if that isn't also obvious from context and variable names, you have bigger naming issues than what to call your dot product function.)



#11 EWClay   Members   -  Reputation: 659

Like
0Likes
Like

Posted 02 March 2013 - 01:52 AM

Personally I prefer to be more specific; i.e. instead of writing a set of overloaded "Dot" functions I'll write "Vector2Dot", "Vector3Dot", "Vector4Dot" (as standalone functions rather than class members) - the reason why is the old chestnut of "reading code is harder than writing it", and this way it's absolutely explicit what types are being operated on. The extra verbosity is something I accept as a fair tradeoff.


Depends what you consider readable. My preference is to remove redundant text in order to make the rest clearer. I generally know whether I'm working with 2D or 3D vectors, so not having VectorN in the function name lets me focus on the important part: the operation.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS