Jump to content

  • Log In with Google      Sign In   
  • Create Account

FREE SOFTWARE GIVEAWAY

We have 4 x Pro Licences (valued at $59 each) for 2d modular animation software Spriter to give away in this Thursday's GDNet Direct email newsletter.


Read more in this forum topic or make sure you're signed up (from the right-hand sidebar on the homepage) and read Thursday's newsletter to get in the running!


How do I centre my model?


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
6 replies to this topic

#1 ronnieb555   Members   -  Reputation: 112

Like
0Likes
Like

Posted 26 March 2013 - 07:59 AM

Hi,

 

I have created a model in 3DSMax and I have gone to import it into my XNA project.

 

On importing it I realised that the model is not centred upon reopening it in 3DSMax I have found that my model is not centred and when I selected the model a huge selection box is drawn around the model but there is nothing there.

 

I have attached my 3DSMax file.

 

Does anyone know how I can centre it or move the centre position?

 

Thanks.

Attached Files



Sponsor:

#2 rouncer   Members   -  Reputation: 291

Like
1Likes
Like

Posted 26 March 2013 - 10:23 AM

Well you just need to know where the origin is (the 0 point) there should be a way to bring it up as a tri-fork with a line in the x y and z direction, in 3dsmax.   Then select all the points and translate it,   you could make a little model centrerer in your XNA app and do it yourself, its not that hard.  It can be cool to do it yourself, cause then you can double it up as a model scaler too, because 3d apps all have different unit scales from each other, and when they are in the game is cooler if they are prescaled relative to each other also.

 

One bit of advice I have, is if its a space ship the origin should be right in the centre space of the object, but if its a person/character, it should be placed between their feet, so the origin is at the toe height.


Edited by rouncer, 26 March 2013 - 10:24 AM.


#3 ronnieb555   Members   -  Reputation: 112

Like
0Likes
Like

Posted 26 March 2013 - 10:28 AM

Well you just need to know where the origin is (the 0 point) there should be a way to bring it up as a tri-fork with a line in the x y and z direction, in 3dsmax.   Then select all the points and translate it,   you could make a little model centrerer in your XNA app and do it yourself, its not that hard.  It can be cool to do it yourself, cause then you can double it up as a model scaler too, because 3d apps all have different unit scales from each other, and when they are in the game is cooler if they are prescaled relative to each other also.

 

One bit of advice I have, is if its a space ship the origin should be right in the centre space of the object, but if its a person/character, it should be placed between their feet, so the origin is at the toe height.

Hi, thanks for the reply.

 

According to 3DSMax it is centred because there is something being selected that shouldn't be, but I have tried un-hiding and un-freezing all and nothing shows up yet it is still selecting something that is not attached to my model.

 

Is there any way you could take a look? I have attached the files to the first post.

 

I am really new to 3DSMax and this is the first model that I have created and still do not really know my way around the software.


Edited by ronnieb555, 26 March 2013 - 10:29 AM.


#4 HardlineDigital   Members   -  Reputation: 255

Like
1Likes
Like

Posted 26 March 2013 - 11:08 AM

I am a Maya user but check your export settings. If you are using the max file, it could be that you are exporting everything in the scene; lights, camera, image planes etc... regardless of selection. I would try a different format like .fbx or .obj and check what you want to include in the export menu options.


Edited by HardlineDigital, 26 March 2013 - 11:08 AM.


#5 ronnieb555   Members   -  Reputation: 112

Like
0Likes
Like

Posted 26 March 2013 - 11:28 AM

Hi,

 

I am exporting it as a .fbx, but within 3DSMax when I select my model it then also selects a blank area as if something is there but there isn't. Because of this, the bounding box is twice as big as needed which is then causing the centre to be offset from the actual model.

 

It is hard to explain so here is an image showing you what I mean.

 

t84zNm5.png

I hope this helps you understand what I mean.



#6 HardlineDigital   Members   -  Reputation: 255

Like
1Likes
Like

Posted 26 March 2013 - 11:41 AM

Did you try Center Pivot and reset xform in that order?



#7 ronnieb555   Members   -  Reputation: 112

Like
0Likes
Like

Posted 26 March 2013 - 11:59 AM

Hey guys I have it fixed now!! biggrin.png

 

To fix it I went into the Hierarchy tab and then selected my model, only the editable poly and not the bone rig. Once I had done that I selected Affect Pivot Only, it then showed me a pivot point which I could then move. I placed it in-between the feet along the floor and now in my XNA project it is centred correctly.

 

Thanks for all the help guys really appreciate it!






Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS