Jump to content

  • Log In with Google      Sign In   
  • Create Account


HLSL debugger appears confused


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
4 replies to this topic

#1 TobiasK   Members   -  Reputation: 126

Like
0Likes
Like

Posted 26 March 2013 - 09:22 AM

As I'm getting back into coding again after a break since before DX10, I'm currently struggling to get the most fundamental things working. One of my problem is that a quad I'm rendering refuses to render in anything but black.

I've tried using the HLSL debugger to see what my very simple vertex shader does, but it's kind of useless... Please see the attached picture.

Can someone explain why the left pane shows the correct data, but the watches in the debugger shows everything as 0 ? Is there a fix for this?

 

Untitled.png



Sponsor:

#2 Zaoshi Kaba   Crossbones+   -  Reputation: 4116

Like
0Likes
Like

Posted 26 March 2013 - 11:26 AM

HLSL compiler might have reordered your code. If you attempt to debug optimized shader it usually jumps all over the place for no reason, you'll need to completely disable optimizations if you want to debug like this, but there's no point if you already see result on the left.



#3 TobiasK   Members   -  Reputation: 126

Like
0Likes
Like

Posted 26 March 2013 - 11:36 AM

I compiled the shader with Debug and SkipOptimizations, are there any other flags I need to set?



#4 Zaoshi Kaba   Crossbones+   -  Reputation: 4116

Like
0Likes
Like

Posted 27 March 2013 - 04:18 AM

Not really. Do values match if you set breakpoint at return?



#5 TobiasK   Members   -  Reputation: 126

Like
0Likes
Like

Posted 27 March 2013 - 04:59 AM

No, they're always 0. I'm starting to suspect this is an issue with Win8...






Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS