Jump to content

  • Log In with Google      Sign In   
  • Create Account


Rendered texture is blank


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
4 replies to this topic

#1 Xcode_t   Members   -  Reputation: 109

Like
0Likes
Like

Posted 08 April 2013 - 11:15 AM

I am attempting to render to a texture, then render the texture to the screen, but it always seems to be blank no matter what I do. Can you guys take a look for me and see what I am missing here?

 

The basic idea is that it renders into the _preRenderColorbuffer, renders the scene into _mainRenderColorBuffer, then uses _postRenderColorbuffer to combine the results and perform all post-render effects, such as bloom effects, antialiasing, et cetera. I currently have it rendering the scene into _preRenderColorbuffer, and simply using _postRenderColorbuffer to render the texture to the screen. It doesn't work at all, from the looks of it, because I just get a black square in the middle of the screen. I am beginning to wonder if I can actually do this on iOS with OpenGL.

Attached Files

  • Attached File  View.zip   8.58KB   48 downloads


Sponsor:

#2 EarthBanana   Members   -  Reputation: 885

Like
1Likes
Like

Posted 08 April 2013 - 01:40 PM

You made sure your shaders are linking and compiling correctly didn't you? I didn't see the vertex or fragment shader source in the zip file - I saw the code for creating them but not the source code for the shaders themselves



#3 Xcode_t   Members   -  Reputation: 109

Like
0Likes
Like

Posted 08 April 2013 - 02:40 PM

Oops. I'll put them up right now.

 

Edit: If you re-download the zip file, they should be there now.


Edited by Xcode_t, 08 April 2013 - 02:41 PM.


#4 Xcode_t   Members   -  Reputation: 109

Like
0Likes
Like

Posted 09 April 2013 - 08:44 AM

Seven downloads and no ideas? Do you all think I should just start over and simplify the code a bit more?



#5 Xcode_t   Members   -  Reputation: 109

Like
0Likes
Like

Posted 15 April 2013 - 01:46 PM

I need an answer here, if anyone has thoughts.






Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS