Jump to content

  • Log In with Google      Sign In   
  • Create Account


Terrain Weird Movement


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
6 replies to this topic

#1 Medo3337   Members   -  Reputation: 665

Like
0Likes
Like

Posted 21 April 2013 - 11:27 PM

I see something like undesired terrain vertex movement on the heights (for far mountains)

 

How do I fix it?

(See the video)

 



Sponsor:

#2 belfegor   Crossbones+   -  Reputation: 2557

Like
0Likes
Like

Posted 22 April 2013 - 04:02 AM

What is the values you set for your near/far clip planes? What is the format of your depth-stencil buffer?



#3 Medo3337   Members   -  Reputation: 665

Like
0Likes
Like

Posted 22 April 2013 - 03:21 PM

Camera new view: 1.0f

Camera far view: 80000.0f

 

 

BackBufferFormat: D3DFMT_X8R8G8B8
AutoDepthStencilFormat: D3DFMT_D24S8


#4 belfegor   Crossbones+   -  Reputation: 2557

Like
0Likes
Like

Posted 22 April 2013 - 03:29 PM

I think that you are using pretty big value for your far plane so there might be precision issue . Try to decrease it as much as possible and see if it flickers then.

 

This might be useful read.


Edited by belfegor, 22 April 2013 - 03:34 PM.


#5 Medo3337   Members   -  Reputation: 665

Like
0Likes
Like

Posted 22 April 2013 - 04:20 PM

@belfegor: What's the appropriate average far plane for FPS game?

 

I don't have problems when I make small terrain in 3Ds Max (size: 4000 x 4000).

 

However, If I made large terrain, like: 50,000 x 50,000 I get this problem.


Edited by Medo3337, 22 April 2013 - 08:31 PM.


#6 VladR   Members   -  Reputation: 722

Like
1Likes
Like

Posted 23 April 2013 - 08:28 AM

Did you read the link you were provided ?

 

If you did, you would understand that the ratio between front/far Z-plane is too big - thus causing the Z-Buffer Shimmering.

 

Reduce the Far plane by at least a factor of 10.0f or increase the Near plane by at least a factor of 10.0f .

 

Yes, that means you will have to rescale the terrain and all objects to preserve the precision of Z-Buffer.

 

If you don't want to do that, your other option is to implement a Linear Z-Buffer - see http://www.mvps.org/directx/articles/linear_z/linearz.htm

 

If you don't want to do that either your last (and by far the easiest) option is to ignore the artifacts :-)


VladR    My 3rd person action RPG on GreenLight:    http://steamcommunity.com/sharedfiles/filedetails/?id=92951596

 


#7 belfegor   Crossbones+   -  Reputation: 2557

Like
0Likes
Like

Posted 23 April 2013 - 08:31 AM

Like in Arma2 where everything is swimming. biggrin.png






Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS