Jump to content

  • Log In with Google      Sign In   
  • Create Account

FREE SOFTWARE GIVEAWAY

We have 4 x Pro Licences (valued at $59 each) for 2d modular animation software Spriter to give away in this Thursday's GDNet Direct email newsletter.


Read more in this forum topic or make sure you're signed up (from the right-hand sidebar on the homepage) and read Thursday's newsletter to get in the running!


torque custom shader


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
No replies to this topic

#1 gordon13   Members   -  Reputation: 103

Like
0Likes
Like

Posted 14 May 2013 - 07:48 PM

Hello I'm learning shader programming and have come across a problem when attempting to add a custom shader to the Torque game engine. I looked at existing shaders that work in torque and tried to make my shader have the same format but the shader doesnt seem to load. theres no error message or anything that might give a clue to what could be wrong.
 
I made this in FX composer and modified the format to match existing torque shaders as best I can. 
It works in fx composer but not in torque. I'm thinking its something to do with the link between the engine and the shader. the shader isnt getting the data it needs and the engine isn't getting the shader stuff it needs  but cant seem to find any useful information or anything I can understand(at least up till now).
 
Could someone have a look at my files and shed some light? Id really appreciate it, thanks.
 
material.cs
 
shader.cs
 
heroV.hlsl
 
heroP.hlsl


Sponsor:



Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS