Jump to content

  • Log In with Google      Sign In   
  • Create Account


Odd Blending Issues


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
3 replies to this topic

#1 Vincent_M   Members   -  Reputation: 560

Like
0Likes
Like

Posted 15 May 2013 - 09:56 AM

I'm trying to perform additive blending for my particle engine, and I'm having some issues getting this right. I'm using a 128x128 texture that's in a 32-bit R8G8B8A8 format. When I try rendering my particle with additive blending using GL_ONE for both source and destination alpha, I get flat colors with overall blending applied to it instead of blending applied from my texture. I have a screenshot showing that below. When I try using GL_SRC_ALPHA for glBlendFunc's source alpha, and GL_ONE for destination alpha, I get better results, but it's still not perfect. As the sprite particles move into themselves, you'll notice the dark, round edges of the particle cutting into adjacent particles. There's a screenshot displaying that as well. I've also attached the 32-bit RGBA texture I'm using as well. I also have GL_DEPTH_TEST disabled.

 

 

EDIT: Here's how I'm shading my sprite in the shader:

gl_FragColor = texture2D(u_texture, v_coord) * v_color;

 

v_color: vec4 vertex color

 

Here are the colors for each sprite:

 

sprite[0]->SetColor(Color32b(255, 64, 64,255));

sprite[1]->SetColor(Color32b(255, 64,255,255));

sprite[2]->SetColor(Color32b(255,255, 64,255));

sprite[3]->SetColor(Color32b( 64, 64,255,255));

 

Attached Thumbnails

  • Screen Shot 2013-05-15 at 8.45.03 AM.png
  • Screen Shot 2013-05-15 at 8.44.45 AM.png
  • particle_texture.png


Sponsor:

#2 C0lumbo   Crossbones+   -  Reputation: 2119

Like
0Likes
Like

Posted 15 May 2013 - 11:02 AM

I think the dark areas on your second image might be an optical illusion. They seem to disappear if I zoom close enough. (or maybe I just haven't had enough sleep recently!).

 

BTW, Is there any alpha testing going on?

 

Edit: Try softening the edges of your particles, by either removing the alpha testing, or blurring the alpha channel and/or the colour channel that's giving the sharp edges.


Edited by C0lumbo, 15 May 2013 - 11:07 AM.


#3 Vincent_M   Members   -  Reputation: 560

Like
0Likes
Like

Posted 15 May 2013 - 10:41 PM

Now that you mention it, I think you're right. I zoomed in, and although I could still see the seam, the pixels didn't appear to be darkening the image. I think it was the steep drop-off in intensity that causes this, now the API, like you mentioned. Still though, should setting the source alpha to GL_ONE still produce the results I've shown? That actually seems to make sense to me, and anything I set to destination source will yield the same results. I've just been told other things in the past, and even setting glBlendFunc's source AND destination to GL_ONE to perform additive blending hasn't given me these results in the past.



#4 C0lumbo   Crossbones+   -  Reputation: 2119

Like
0Likes
Like

Posted 16 May 2013 - 02:06 AM

Still though, should setting the source alpha to GL_ONE still produce the results I've shown?

 

Probably. Although without seeing the source texture it's a little hard to be sure.

 

I think that something that's confusing matters for you is that I believe you have a circle shape with a very sharp fall off in your source texture's RGB channel, and you have a circle shape with a smooth fall off in your source texture's alpha channel. Now, with additive blending that uses alpha, it doesn't seem like a good idea to have both as they're multiplying together. For simplicity, I'd recommend you choose one or the other. i.e. Either the alpha channel or the RGB channel of your texture should be pure white.

 

As an aside, it's just occurred to me that maybe the RGB of your source texture is actually a square of pure white, but you're using .pngs. It's very easy to fall into problems with .pngs either due to premultiplication, or because some tools (like photoshop's default png plugin), don't bother storing colour values for transparent texels.

 

If you want to use GL_ONE, GL_ONE blending, but don't want your alpha channel to be completely ignored, you could stick a line like "gl_FragColor.xyz *= gl_FragColor.w" at the end of your pixel shader. That should make it equivalent to the GL_SRC_ALPHA, GL_ONE case.






Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS