Jump to content

  • Log In with Google      Sign In   
  • Create Account

Specular + Normal Issue


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
2 replies to this topic

#1 riuthamus   Moderators   -  Reputation: 5779

Like
0Likes
Like

Posted 20 May 2013 - 11:39 PM

gallery_1_371_32279.jpg

 

Any clue why speculars and normals might be doing something like that? When put into 3dmax we get a similar result.

 

gallery_1_371_113611.png

 

No clue why we get this.... any ideas would be great!



Sponsor:

#2 unbird   Crossbones+   -  Reputation: 6007

Like
2Likes
Like

Posted 21 May 2013 - 09:53 PM

Not sure what I'm looking at here, you give too little information. Shader code and/or technique used would help and probably some debug renderings (normals, specular alone).

#3 riuthamus   Moderators   -  Reputation: 5779

Like
0Likes
Like

Posted 21 May 2013 - 11:04 PM

Sorry, not the coder... and they are often too lazy to actually make the posts. So i got with what i know. I will direct one of them here and have them post with more detail.

 

As for what I do know. When we are in block mode there is no issues with specular, but when you go into the dual contouring version of the rendering we get this odd flat specular. Our terrain gen guy suspects it is the method in which we are calling the specular but he is not sure as he doesnt do graphics coding.






Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS