Jump to content

  • Log In with Google      Sign In   
  • Create Account

OpenGL Auxiliary


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
2 replies to this topic

#1 BornToCode   Members   -  Reputation: 927

Like
0Likes
Like

Posted 16 June 2013 - 01:05 PM

When i create the open gl context. I set auxialiary buffers to 0, but when i run the application in gdebugger. It still is creating the Aux buffers. Is there anyway to force it not to create those buffers since i am not using any of them.

 

Thanks


Edited by BornToCode, 16 June 2013 - 01:06 PM.


Sponsor:

#2 tanzanite7   Members   -  Reputation: 1294

Like
1Likes
Like

Posted 17 June 2013 - 03:00 PM

There is no way to explicitly disallow them - but there would be no point to do so anyway even if the option existed.

 

Aux buffers are created only when "used" (ie. referenced etc) (*) - gdebugger "uses" them (to show that there is nothing going on). In short: they are not created when you do not run through gdebugger and do not use them in your code.

 

(*) techincally, it is implementation detail - but you can safely assume every ogl diver that ever existed works that way.



#3 BornToCode   Members   -  Reputation: 927

Like
0Likes
Like

Posted 17 June 2013 - 11:22 PM

Thanks.






Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS