Jump to content

  • Log In with Google      Sign In   
  • Create Account

We're offering banner ads on our site from just $5!

1. Details HERE. 2. GDNet+ Subscriptions HERE. 3. Ad upload HERE.


Help with Glut in Dev-C++


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
4 replies to this topic

#1 codeman_nz   Members   -  Reputation: 230

Like
0Likes
Like

Posted 30 October 2013 - 07:32 PM

I am losing my mind here.  I just downloaded the glut devpak and created a new project using the glut template but I get errors like this:

[Linker Error] undefined reference to `_imp____glutInitWithExit@12'

 

I know this is linker error and I need to link the glut library but I have already done that like this:

-lglut32 -lglu32 -lopengl32 -lwinmm -lgdi32

 

But I still get that error and I have no idea how to fix it.



Sponsor:

#2 Poigahn   Crossbones+   -  Reputation: 520

Like
1Likes
Like

Posted 31 October 2013 - 04:16 AM

Did you down load into the Dev C++ folder ?

 

Verify where it is on the Disk Drive and make Certain that folder location is referenced in your Project Settings


Your Brain contains the Best Program Ever Written : Manage Your Data Wisely !!


#3 jbadams   Senior Staff   -  Reputation: 19072

Like
2Likes
Like

Posted 31 October 2013 - 04:23 AM

Are you using the original Bloodshed Dev-C++ (strongly not recommended -- it's horribly out of date and buggy), or are you using one of the updated versions (Orwell Dev-C++ or wxDev-C++ -- of the two I would recommend Orwell Dev-C++)?  What version of Windows are you using?

 

...and where did you get the devpak from?  Is it up-to-date?



#4 Brother Bob   Moderators   -  Reputation: 8454

Like
2Likes
Like

Posted 31 October 2013 - 04:26 AM

If the linker only complains about the WithExit-functions, then it is probably the "atexit-hack". You can disable it with #define GLUT_DISABLE_ATEXIT_HACK before including the GLUT header.

#5 codeman_nz   Members   -  Reputation: 230

Like
0Likes
Like

Posted 31 October 2013 - 01:04 PM

Yes I downloaded into the dev c++ folder.

 

I am using wxDev-c++ running on windows 7

 

I downloaded the devpak from the devpak website and I think it is up to date.

 

No that is not the only one.  It is coming back with a whole lot of errors.






Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS