Jump to content

  • Log In with Google      Sign In   
  • Create Account

double vertices problem


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
4 replies to this topic

#1 proanim   Members   -  Reputation: 441

Like
0Likes
Like

Posted 15 November 2013 - 05:07 PM

I came across one annoying problem recently involving smoothing groups in models. Mainly 3ds max obj exporter problem. Since I will be using obj format for static meshes, the problem is that when exporting from max to obj format it exports everything except smoothing groups, so entire model looks like it uses one for entire model, and as a result it looks like it is completely smoothed out.

 

Later i found that a way to avoid this problem is to detach parts of the model that use different smoothing groups so there is no issue. But then I am concerned about memory consumption of this since every detached piece of the model has duplicate vertices in places where it would be connected it smoothing groups were working.

 

For example if you have cube model with 8 vertices, since it looks wrong in the engine, you would detach each side of the cube and have 6 sides with 4 vertices, and there is the problem i am trying to address.

 

My question here is - can this pose a threat to performance or memory consumption since there might be many static meshes in the scene? This is considering modern day hardware.



Sponsor:

#2 Samith   Members   -  Reputation: 2256

Like
1Likes
Like

Posted 15 November 2013 - 05:46 PM

This really depends. It's something you're just going to have to time and see if it's too slow for you or not. If you're trying to get some kind of facet shading, then you can look into alternatives like computing the face normal from the derivative of the position in the pixel shader or computing the face normal in the geometry shader and see if those perform better for you. If facet shading isn't what you want, and you really just want some surfaces to have separate smoothing groups, then there isn't much else you can do than duplicate the edge verts. The extra cost will be a function of how many verts you actually duplicate.  If you're only duplicating ~1% of your verts, then you might not notice a huge performance drop. If you're duplicating 100% of your verts, then you might really notice it (if your static geometry is expensive, if not, then maybe even duplicating 100% of the verts won't significantly impact your performance). You really just have to test the performance and ask yourself if the feature is worth the cost.



#3 ankhd   Members   -  Reputation: 1299

Like
0Likes
Like

Posted 16 November 2013 - 08:01 PM

Hello there.

This sounds like a shader and normal type thing. what I thought smoothing groups was some type value to fake roundness on a sharp bend this is all done in shaders now hey????.. where am I.



#4 L. Spiro   Crossbones+   -  Reputation: 13639

Like
1Likes
Like

Posted 17 November 2013 - 11:35 PM

Smoothing groups are not a concept specifically related to either game engines or the .OBJ format.

The engine only needs to load the normals.  Smoothing groups are an edit-time artifact that impact the normals, but there is no reason these need to be loaded by your engine nor stored in the .OBJ file as long as you have the original 3DS Max file.

 

If you are unable to export a cube with hard edges, you are either doing something wrong in 3DS Max, the .OBJ is corrupted, or your loading process is buggy.

I would first verify your knowledge of how 3DS Max works, since having multiple smoothing groups on a single mesh in no way requires duplicating vertices (in this case I am talking only about positions)—it simply changes how the normals are generated in the final export (which would cause positional data for each vertex to be duplicated once for each unique normal associated with it in the final “vertex buffer data stream”).

Export as .FBX and reimport it without selecting to import smoothing groups—it should still look perfectly fine if your skills at 3DS Max are not in err.

If you confirm that, then the problem is either the .OBJ exporter or your importer.  In general, .OBJ is not a very useful format, and in any case you should always be exporting to your own custom format; a game engine should not be loading .OBJ, .DAE, .FBX, etc. directly.  This won’t solve your current issue, however.

 

 

L. Spiro


Edited by L. Spiro, 18 November 2013 - 04:40 AM.

It is amazing how often people try to be unique, and yet they are always trying to make others be like them. - L. Spiro 2011
I spent most of my life learning the courage it takes to go out and get what I want. Now that I have it, I am not sure exactly what it is that I want. - L. Spiro 2013
I went to my local Subway once to find some guy yelling at the staff. When someone finally came to take my order and asked, “May I help you?”, I replied, “Yeah, I’ll have one asshole to go.”
L. Spiro Engine: http://lspiroengine.com
L. Spiro Engine Forums: http://lspiroengine.com/forums

#5 Krohm   Crossbones+   -  Reputation: 3129

Like
0Likes
Like

Posted 18 November 2013 - 01:28 AM


My question here is - can this pose a threat to performance or memory consumption since there might be many static meshes in the scene? This is considering modern day hardware.
I don't think so. It's just standard practice. But as above noted, you sure need to rethink your loading since it sure looks wrong.

Keep in mind that in graphics, a vertex is not a position. The graphic vertex is the full vector including position, normal, texcoords, so ...


For example if you have cube model with 8 vertices, since it looks wrong in the engine, you would detach each side of the cube and have 6 sides with 4 vertices, and there is the problem i am trying to address.

A cube only has 4 vertices if you have no lighting. If you have lighting, then the cube will have 6*4 vertices as every face got a different normal. Do not think at graphic vertices as mere positions!


so entire model looks like it uses one for entire model, and as a result it looks like it is completely smoothed out
I'm surprised Max smoothes across different models! Blender doesn't. Anyway, there is a setting somewhere to control the maximum smooth angle, check it out!




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS