Jump to content

  • Log In with Google      Sign In   
  • Create Account

Banner advertising on our site currently available from just $5!


1. Learn about the promo. 2. Sign up for GDNet+. 3. Set up your advert!


error:HRESULT:0x80070005, access denied.


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
9 replies to this topic

#1 nickme   Members   -  Reputation: 205

Like
0Likes
Like

Posted 08 December 2013 - 08:25 PM

hi

i compiled and ran a sdl test program in vs 2013 express.  however, after i exported the template and tried to create a project with that template, i got an access denied exception.  

i had done this with directx and opengl without incident.

any suggestion will be appreciated.

 

thanks


Edited by nickme, 08 December 2013 - 08:27 PM.


Sponsor:

#2 Vortez   Crossbones+   -  Reputation: 2704

Like
0Likes
Like

Posted 08 December 2013 - 08:30 PM

I little more information would help... Like where does it crash, and some revelent code snippets around where it crash for example.



#3 nickme   Members   -  Reputation: 205

Like
0Likes
Like

Posted 08 December 2013 - 09:09 PM

hi Vortez:

 

thanks for your reply.

 

after i clicked my template icon in the new project dialogue windows and the ok button on the lower right of the dialogue window, a small window popped up and said that "operation the complete successfully.  after i clicked the OK button in the small window, that small window closed and another small window popped up and said "Access is denied. (exception from RESULT:0x80070005 (E_ACCESSDENIED)).

 

after that i browsed to the newly created folder and saw that the folder is empty. and the solution explorer is blank, there is no file or folder.

 

i should indicate that i was setting up for sdl 2.0.


Edited by nickme, 08 December 2013 - 09:26 PM.


#4 nickme   Members   -  Reputation: 205

Like
0Likes
Like

Posted 08 December 2013 - 09:46 PM

hi

 

now i found out that directx and opgengl template had the same problem as well. :(.



#5 Hodgman   Moderators   -  Reputation: 34986

Like
0Likes
Like

Posted 08 December 2013 - 10:22 PM

Sounds like a windows file-system problem rather than something to do with SDL or visual studio... Do you have write-permission at the location where you're trying to create the files? Does running visual studio as an administrator help?



#6 nickme   Members   -  Reputation: 205

Like
0Likes
Like

Posted 09 December 2013 - 10:25 AM

hi hogman:

 

i checked to see the property of the file folder that i created the project in.  it attribute said "read only".  i unchecked and apply it and later on open it property again and see that the read only checkbox is checked again. i created the folder by crt,shift,N.  is that the problem?

 

how can i change it so that it is not read only?

 

thanks


Edited by nickme, 09 December 2013 - 10:30 AM.


#7 Vortez   Crossbones+   -  Reputation: 2704

Like
0Likes
Like

Posted 09 December 2013 - 02:14 PM

Im not sure if you're tolling or what...

 

Unchecking the read only box of that directory and selecting "apply to this directory and all sub directory and files" should do it.

 

If your files are on a cd-rom or some read only media then it's not gonna work, of course... If the file are in a networked folder, make sure you have write permission.



#8 nickme   Members   -  Reputation: 205

Like
0Likes
Like

Posted 09 December 2013 - 02:17 PM

hi

i tried to run as administrator but the same problem exist.

 

i did unchecked the attributes "read only" of the folder.  but when i go back to see it again, the attributes is "read only" again.  i did click the apply button before closing the window.

 

my pc has two hard drive.  one hard disk(D:\) and ssd(C:\).  the folder i created project in is in hard disk(D:\).  when i right click all the folders in my d:\, they all have attributes with "read only" checked.  although i can create new projects in the folder, i cannot create new project with template.

 

i think the problem is with vs express 2013 desktop.  what do you think?

 

thanks for helping.

Attached Thumbnails

  • Screenshot (1).png

Edited by nickme, 09 December 2013 - 02:40 PM.


#9 mhagain   Crossbones+   -  Reputation: 8692

Like
1Likes
Like

Posted 09 December 2013 - 03:56 PM

The "read only" attribute will always be set on folders, but that's not what you're being advised to look at here.  Instead, when you right-click on the folder, go to the Security tab and check the permissions in there.

 

 

i think the problem is with vs express 2013 desktop.  what do you think?

 

I don't think so - 99 times out of 100, whenever someone thinks they've got a problem with their tools, it turns out that the real problem was that they were doing something wrong themselves all along.  It's highly likely that your case is no different.


Edited by mhagain, 09 December 2013 - 03:58 PM.

It appears that the gentleman thought C++ was extremely difficult and he was overjoyed that the machine was absorbing it; he understood that good C++ is difficult but the best C++ is well-nigh unintelligible.


#10 nickme   Members   -  Reputation: 205

Like
0Likes
Like

Posted 09 December 2013 - 04:17 PM

HI Mhagin:

 

i did what you asked (right click on the folder and go to the security tab and see that it is under my name and it also showed my email address) and saw that all it's six permissions (full control, modifies, read & execute, list folder contents, read, and write) are checked.  then i did it again and the result is the same, access denied.

 

sorry


Edited by nickme, 09 December 2013 - 04:21 PM.





Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS