Jump to content

  • Log In with Google      Sign In   
  • Create Account

FREE SOFTWARE GIVEAWAY

We have 4 x Pro Licences (valued at $59 each) for 2d modular animation software Spriter to give away in this Thursday's GDNet Direct email newsletter.


Read more in this forum topic or make sure you're signed up (from the right-hand sidebar on the homepage) and read Thursday's newsletter to get in the running!


Bit mask math


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
12 replies to this topic

#1 MARS_999   Members   -  Reputation: 1297

Like
0Likes
Like

Posted 03 February 2014 - 12:26 AM

How can I combine this into one statement? 

 

I tried this but no luck

if(id &= ~(NX::COLLISION_ID_IsPickable | NX::COLLISION_ID_IsHighlightable) == 200)

//do something 

 

 

irr::s32 id = selectedNode->getID();
if(id &= ~NX::COLLISION_ID_IsPickable)
if(id &= ~NX::COLLISION_ID_IsHighlightable)
if(id == 200)
{
//do something
}


Sponsor:

#2 MARS_999   Members   -  Reputation: 1297

Like
3Likes
Like

Posted 03 February 2014 - 12:30 AM

if((id &= ~(NX::COLLISION_ID_IsPickable | NX::COLLISION_ID_IsHighlightable)) == 200)

 

sigh fat fingered my ()

 

now it works



#3 SeanMiddleditch   Members   -  Reputation: 7257

Like
5Likes
Like

Posted 03 February 2014 - 01:41 AM

... why do you want to write such a monstrosity? Clarity is way more important than conciseness. Split it up and simplify it. The assignment operation inside a condition is pretty scary. The magic number "200" is terrifying (it's mildly more clear if the hex 0xC8 is used but a named constant would be _strongly_ preferable).

#4 iMalc   Crossbones+   -  Reputation: 2314

Like
1Likes
Like

Posted 03 February 2014 - 02:00 AM

Surely this is more readable?!:

id &= ~(NX::COLLISION_ID_IsPickable | NX::COLLISION_ID_IsHighlightable);
if (id == 200)

Edited by iMalc, 03 February 2014 - 02:01 AM.

"In order to understand recursion, you must first understand recursion."
My website dedicated to sorting algorithms

#5 Krohm   Crossbones+   -  Reputation: 3261

Like
0Likes
Like

Posted 03 February 2014 - 02:17 AM

To elaborate on Sean's, I have to admit I have bought myself quite some peace of mind since I've restricted bitmask usage to serialization only. Just use structs.

auto props = selectedNode->getFlags();
if(props.canPick && props.canHilight) {
//do something
}

The profiler will tell you if code is hot or cold. Cold code has no point in not having maintainance and readability as priorities. Even if the code is hot, I would be careful in considering this an optimization.



#6 Scarabus2   Members   -  Reputation: 556

Like
0Likes
Like

Posted 03 February 2014 - 09:14 AM

C++ wizardry like that drives me nuts, and is a clear sign of an inexperienced programmer. SeanMiddleditch is totally right.
Clarity always wins over a couple of cycles worth of optimization, especially in a team environment where you aren't the only one dealing with the code. Basically, if you're trying to reduce line counts for arbitrary reasons, then you're doing it wrong. Bit masking and bit shifting is almost always a sign of over-complication.
 


Edited by Scarabus2, 03 February 2014 - 09:30 AM.

visualnovelty.com - Novelty - Visual novel maker

#7 Álvaro   Crossbones+   -  Reputation: 13933

Like
3Likes
Like

Posted 03 February 2014 - 09:32 AM


I've programmed C++ for nearly 10 years and I have no idea what "id &= ~NX::COLLISION_ID_IsPickable" even does. (I do, but I'd have to look it up to be sure.)

 

Well, you must not have done a whole lot of bit manipulations in your 10 years of C++. In any case, a helper function can add clarity to the code, so I would do something like this:

 

void clear_bits(irr::s32 &x, irr::s32 bits_to_erase) {
  x &= ~bits_to_erase;
}
 
//...
clear_bits(id, NX::COLLISION_ID_IsPickable);


#8 Ameise   Members   -  Reputation: 766

Like
0Likes
Like

Posted 03 February 2014 - 11:09 AM

Bit fields might also help in this situation, since you can retain the packed nature of having bit-based data but instead accessing the data as C++ struct members for clarity.



#9 Trienco   Crossbones+   -  Reputation: 2224

Like
0Likes
Like

Posted 03 February 2014 - 11:03 PM

Bit fields might also help in this situation, since you can retain the packed nature of having bit-based data but instead accessing the data as C++ struct members for clarity.

 

One annoying detail to keep in mind: the order in which bits are assigned is not defined. Not an issue if everything is happening on one machine and within the same application.

 

Still, not knowing if setting a particular field will effectively result in 0x01 or in 0x80 is always making me nervous.


f@dzhttp://festini.device-zero.de

#10 MARS_999   Members   -  Reputation: 1297

Like
0Likes
Like

Posted 03 February 2014 - 11:23 PM

Álvaro nice function. Like that...

 

The 200 isn't a permanent thing, it was more of a hurry up and post it!

 

I am using irrlicht and the id is a unsigned int and they are bit masking with the pipe | to do collision detection. So I am looking for ways to set and clear and change them without much headache...

 

Thanks!



#11 osmanb   Crossbones+   -  Reputation: 1628

Like
0Likes
Like

Posted 04 February 2014 - 08:01 AM

Although I share the concerns that everyone else has about the readability and maintainability of this code (I'd stick with something clear over something short)... it's also worth pointing out that pretty much every alternate form that people have posted does not have the same effect as the original code. If you do anything with id after the code that you posted, then the final value of id varies, depending on whether or not it had the Pickable flag set. (Highlighted is only cleared if id had any bit other than pickable). In fact, I'm beginning to seriously doubt that this code does what you think it does. What were you actually trying to do with this logic?



#12 Álvaro   Crossbones+   -  Reputation: 13933

Like
0Likes
Like

Posted 04 February 2014 - 08:08 AM

Oh, I thought the extra `if's were typos. Indentation matters!

#13 Brother Bob   Moderators   -  Reputation: 8625

Like
1Likes
Like

Posted 04 February 2014 - 11:26 AM

Although I share the concerns that everyone else has about the readability and maintainability of this code (I'd stick with something clear over something short)... it's also worth pointing out that pretty much every alternate form that people have posted does not have the same effect as the original code. If you do anything with id after the code that you posted, then the final value of id varies, depending on whether or not it had the Pickable flag set. (Highlighted is only cleared if id had any bit other than pickable). In fact, I'm beginning to seriously doubt that this code does what you think it does. What were you actually trying to do with this logic?

I actually thought so too that the solutions are different, until I realized that the if-statements clears a bit but checks the entire value and not just that cleared bit. The only way to break on the first of the three if statements is if no bits at all are set in the original value. You are right that highlighted is only cleared if something other than pickable is set, but if nothing else is set then highlighted cannot be set either so there's nothing to clear in the first place (nor is there anything that can be equal to 200).

 

Whether you clear them all at the same time, as MARS and iMalc suggested in their solutions, or one at a time as MARS did in his original code actually makes no difference. All codes effectively clear both bits and checks the remaining value for 200. The net result is the same in all cases, and that includes whether the last if-statement (=200) is take or not, and what the final value of id is.

 

In Krohm's variant though it makes a difference since it doesn't modify anything at all. And, of course, like most other here I prefer a non-modifying variant.


Edited by Brother Bob, 04 February 2014 - 11:27 AM.





Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS