Jump to content

  • Log In with Google      Sign In   
  • Create Account

We're offering banner ads on our site from just $5!

1. Details HERE. 2. GDNet+ Subscriptions HERE. 3. Ad upload HERE.


#error DXUT requires a Unicode build


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
3 replies to this topic

#1 Deek880   Members   -  Reputation: 126

Like
0Likes
Like

Posted 20 February 2014 - 12:17 AM

I'm running into a bit of a problem:

 

I'm using Microsoft Visual 6.0. It's basically a 1998 compiler with windows XP. I'm using directx 9.0b.

 

I've been through all DirectX SDK's up to 10.0.

 

I'm down to the following problem. #error "DXUT requires a Unicode build".

 

I've tried to put it in the pre processor directive and all that but it's not working.

 

What can I do other than buy a new computer and a new compiler. Does anyone know how to re write this file so that it is in ansi, or anything else?



Sponsor:

#2 ryan20fun   Members   -  Reputation: 1100

Like
0Likes
Like

Posted 20 February 2014 - 08:32 AM

Have you tried using the switch in project settings ?

You could also get the free version of visual studio that is known as "Visual studio YEAR Express"


Never say Never, Because Never comes too soon. - ryan20fun

Disclaimer: Each post of mine is intended as an attempt of helping and/or bringing some meaningfull insight to the topic at hand. Due to my nature, my good intentions will not always be plainly visible. I apologise in advance and assure you I mean no harm and do not intend to insult anyone.

#3 Deek880   Members   -  Reputation: 126

Like
0Likes
Like

Posted 21 February 2014 - 05:07 PM

There is no "switch button" in my version of Visual Studio. However I figured it out, for anyone else that has this problem:

 

1. Anywhere you see MBCS (mulitbyte character set) project ->settings->C++ General, replace MBSC with UNICODE, and _UNICODE.

UNICODE for the compile and _UNICODE for the run time library.

 

Hit the resources link and add the same to Pre-Processor definitions and Project Options.

 

Then hit the MIDL button and do the same.

 

Now it will compile without the unicode error.

 

However now that I've gotten past that I'm getting another error "usp10.h" no such file or directory. This is true I've done searches and the file doesn't exist on my computer.

I've gotten the latest updates for windows XP and my compiler. What file or library am I still missing



#4 ryan20fun   Members   -  Reputation: 1100

Like
0Likes
Like

Posted 22 February 2014 - 06:52 AM

However now that I've gotten past that I'm getting another error "usp10.h" no such file or directory.

Well it appears to be part of the Windows SDK version 7.0A( visual studio 2010 ).

 

Is there a reason that you are not using a newer version of Visual Studio/DirectX ?


Never say Never, Because Never comes too soon. - ryan20fun

Disclaimer: Each post of mine is intended as an attempt of helping and/or bringing some meaningfull insight to the topic at hand. Due to my nature, my good intentions will not always be plainly visible. I apologise in advance and assure you I mean no harm and do not intend to insult anyone.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS