Jump to content

  • Log In with Google      Sign In   
  • Create Account

Multisampling Gamma Correction Problem


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
12 replies to this topic

#1 zz2   Members   -  Reputation: 278

Like
0Likes
Like

Posted 01 March 2014 - 04:16 AM

Hi,

I have multisampled rendertarget where I use red channel as some sort stencil data, but the problem is I get incorrect results around borders if "Antialiasing - Gamma Correction" is set to on in Nvidia Control Panel. Is there a way to turn that off while I am writing to that specific render target (if user has it enabled in graphics card's control panel)?

 

Edit: screenshots
Antialiasing - Gamma Correction set to

 

On
http://i.cubeupload.com/stXIKw.png

 

Off

http://i.cubeupload.com/QaCO9K.png

 

While creating these two screenshot I noticed that artifacts caused by gamma correction are also visible in other areas. Like in background text. Text is outlined when gamma correction is on (but should not be). Text is not rendered with bitmap font, but as vector shapes.


Edited by zz2, 03 March 2014 - 04:33 AM.


Sponsor:

#2 kauna   Crossbones+   -  Reputation: 2848

Like
0Likes
Like

Posted 01 March 2014 - 07:02 AM

What texture format are you using for your render target? 

 

Cheers!



#3 zz2   Members   -  Reputation: 278

Like
0Likes
Like

Posted 01 March 2014 - 12:45 PM

32-bit ARGB pixel format with alpha, using 8 bits per channel.



#4 kauna   Crossbones+   -  Reputation: 2848

Like
0Likes
Like

Posted 01 March 2014 - 02:57 PM

Is it a format with _SRGB ending?

 

[edit]If you need only one channel, you could use either DXGI_FORMAT_A8_UNORM format or store the data in the alpha component. Typically the alpha component isn't affected by gamma correction. 

 

Cheers!


Edited by kauna, 01 March 2014 - 04:44 PM.


#5 zz2   Members   -  Reputation: 278

Like
0Likes
Like

Posted 01 March 2014 - 05:18 PM

I don't know. I am using XNA framework and I am not sure which exact underlying D3D surface it uses. Here is the full list of supported surfaces: SurfaceFormat Enumeration (I'm using Color surface).

 

I tried setting SRGBWriteEnable  to false in shader as described here, but I get compiler error that it is obsolete.

 

However the plan is to migrate whole project to MonoGame after it is feature complete (MonoGame acts as drop in replacement for XNA). So even if correcting this might not be possible in pure XNA, any hack for MonoGame would be OK too. smile.png

 

Edit: Two channels are needed. One contains alpha override data and the other stencil mask that specifies where alpha override gets applied. Stencil mask is written to red channel and alpha override to alpha channel.

I'm trying to limit what graphic features are used to XNA's Reach profile, so that porting mobile platforms would be easier later on. (Or at least have an alternative renderpath that for Reach profile.)
Reach profile's texture formats are: Color, Bgr565, Bgra5551, Bgra4444, NormalizedByte2, NormalizedByte4, Dxt1, Dxt3, Dxt5


Edited by zz2, 02 March 2014 - 03:22 AM.


#6 DwarvesH   Members   -  Reputation: 471

Like
0Likes
Like

Posted 02 March 2014 - 03:50 AM

XNA 4 no longer supports SRGBWriteEnable and you can consider it set to false. So you can assume that XNA won't do any gamma operations. Now, what Nvidia overrides this to is completely different.



#7 zz2   Members   -  Reputation: 278

Like
0Likes
Like

Posted 02 March 2014 - 07:59 AM

Can Nvidia's override be controlled/disabled?



#8 DwarvesH   Members   -  Reputation: 471

Like
0Likes
Like

Posted 02 March 2014 - 12:27 PM

Well, you should balance your rendering pipeline around default settings. There is no way one setting will mix well with any configurable overrides.

 

My default is "On".

 

On the other hand, it says that it only affects OpenGL programs. So there is something strange going on.

 

You say you are having problems around borders and you mentioned render targets. You gave far too little detail, so let me do some wild guessing: maybe you have your device set up with antialiasing and you are drawing the render target using a full screen quad and the border you are getting is due to to the full screen quad borders getting antialiased with the background?

 

Edit: Sorry, I forgot you mentioned XNA. So a limited DirectX 9. I would double check what I said above. Try to create you device with PreferMultisampling false, and when you create the render target give that a multisample count.


Edited by DwarvesH, 02 March 2014 - 12:29 PM.


#9 zz2   Members   -  Reputation: 278

Like
0Likes
Like

Posted 03 March 2014 - 02:41 AM

Border appears around stencil masked shape not around full screen quad. This happens only when "Antialiasing - Gamma Correction" is set to on. If its turned off it renders correctly. I will post screenshots with that setting turned on and off. I tired creating device with PreferMultisampling false and multisampled render targets. The problem still persists. My guess is that artifacts are caused because I save stencil data into red channel which is being gamma corrected around stencil shape's edges (stencil mask is created by rendering 2D vector shape into multisampled render target).

 

Which driver version are you using. It doesn't say that it only affects OpenGL programs in the version I have installed, that's v331.93. Maybe they changed description? Researching the subject I found this forum thread, where OP claims that description in Nvidia control panel is false because Antialiasing - Gamma Correction option also affects Direct3D games like Half-Life 2 and Call of Duty.



#10 DwarvesH   Members   -  Reputation: 471

Like
0Likes
Like

Posted 03 March 2014 - 03:14 AM

Hmmm, well now. I generally don't expect the docs to lie.

 

I am no gamma correction expert, but I do recognize its value and  always use it. Having gamma corrected AA is the correct way to do it. All multisampling must be corrected for gamma and HDR for correct results.

 

So I guess that there is no way around having your red channel corrected for AA and not corrected for the rest, because XNA does not support sRGB. There may be a few things to try. For starters, you could use the alpha channel, but that may not work due to multiple issues, like premultiplication/non premultiplication. And you could try using a real stencil buffer.



#11 zz2   Members   -  Reputation: 278

Like
0Likes
Like

Posted 03 March 2014 - 04:19 AM

I have added screenshots to first post. While creating screenshots I have noticed that artifacts are visible in other areas too (not just when creating alpha override effect).

 

1st error is visible as a second outline in alpha override effect.

 

2nd error is that background text is outlined when gamma correction is set to on, but there should be no outline. I just discovered this. Background text is rendered as vector shapes (not with SpriteFont).

 

When gamma correction is set to off image is rendered correctly.


Edited by zz2, 03 March 2014 - 04:41 AM.


#12 DwarvesH   Members   -  Reputation: 471

Like
0Likes
Like

Posted 04 March 2014 - 07:23 AM

Hmmm, what about turning multisampling off before you draw that masked shape and then turning it on again?

 

Try creating a new RasterizerState with MultiSampleAntiAlias = false. Set this state before the draw call. I have no idea if this would work, but maybe worth a try.


#13 zz2   Members   -  Reputation: 278

Like
0Likes
Like

Posted 04 March 2014 - 10:47 AM

With that settings I get jagged edges. I am kind of lost on what else to try.






Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS