Jump to content

  • Log In with Google      Sign In   
  • Create Account


Render monkey error C0118


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
1 reply to this topic

#1 PeymanKOP   Members   -  Reputation: 108

Like
0Likes
Like

Posted 01 April 2014 - 11:30 AM

i'm find Render monkey to work and practice in openGL es2.0 shader language. as i start the program i add a new default opengl es 2.0 in effect workspace but when it opens i see lots of error in output window,the error is this for both fragment and vertex shader:

error C0118: macros prefixed with 'GL_' are reserved

and here is my vertex shader:

uniform mat4 matViewProjection;
attribute vec4 rm_Vertex;
void main(void)
{
   gl_Position = matViewProjection * rm_Vertex;
}

and fragment:

#ifdef GL_FRAGMENT_PRECISION_HIGH
   // Default precision
   precision highp float;
#else
   precision mediump float;
#endif

void main(void)
{
   gl_FragColor = vec4( 0.4, 0.0, 0.9, 1.0 );
}

it's so simple! and in addition i try Render monkey examples but still got this error in every vertex and fragment shader ! so what is the problem with it?



Sponsor:

#2 render donkey   Members   -  Reputation: 138

Like
0Likes
Like

Posted 05 April 2014 - 01:37 PM

hi

all shaders of the samples can be compiled successfully on my computer.

but i'm encountering a black screen.

 

is  there something wrong with my video card?

my card is nVidia GT 640 and GT650

thanks.






Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS