Jump to content

  • Log In with Google      Sign In   
  • Create Account

We're offering banner ads on our site from just $5!

1. Details HERE. 2. GDNet+ Subscriptions HERE. 3. Ad upload HERE.


msaa


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
2 replies to this topic

#1 NEvOl   Members   -  Reputation: 176

Like
0Likes
Like

Posted 20 June 2014 - 08:16 AM

Hi, i try add msaa to my project, but eglChooseConfig(g_display, configAttributes, &config, 1, &countConfig) returning countConfig = 0, how i can check support msaa ?

code:

EGLint configAttributes[] =
    {
        EGL_RED_SIZE,       8,
        EGL_GREEN_SIZE,     8,
        EGL_BLUE_SIZE,      8,
        EGL_ALPHA_SIZE,     8,
        EGL_DEPTH_SIZE,     24,
        EGL_STENCIL_SIZE,   8,
EGL_SAMPLE_BUFFERS, 1,
EGL_SAMPLES,        4,
        EGL_NONE
    };
 
if(EGL_FALSE == eglChooseConfig(g_display, configAttributes, &config, 1, &countConfig)) || countConfig != 1)
{
MB(L"eglChooseConfig - Failed");
return 0;
}

 



Sponsor:

#2 Wh0p   Members   -  Reputation: 340

Like
0Likes
Like

Posted 24 June 2014 - 02:48 AM

I'm not a pro on opengl es but the I guess standard method would be drawing to a multisample framebuffer object you have created with glCreateFramebuffers () and when you have finished rendering resolve the multisample framebuffer to you backbuffer with glBlitFramebuffer ().

Hope that helps.



#3 Xycaleth   Members   -  Reputation: 1272

Like
0Likes
Like

Posted 24 June 2014 - 06:32 AM

Try setting EGL_SAMPLES to 1 and you should be returned a list of configs that support 1 or more samples. If there are none then your graphics driver is saying it doesn't support MSAA configs.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS