Jump to content

  • Log In with Google      Sign In   
  • Create Account

No clipping. Ever.


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
5 replies to this topic

#1 Goodlife   Members   -  Reputation: 122

Like
Likes
Like

Posted 18 January 2000 - 04:36 AM

Hi all-- Can I set d3d to not clip anything that''s too close to the camera? If an object got behind the camera, I would rather see it as a huge pixellated mess than have it vanish completely, exposing the innards of my graphics. In my interface, the user ''never'' gets behind an object, since they''re viewing it from above. But when I zoom the camera in, sometimes I get inside things, and I''d rather they just got bigger. Thanks in advance! --Goodlife

Sponsor:

#2 Anonymous Poster_Anonymous Poster_*   Guests   -  Reputation:

Likes

Posted 18 January 2000 - 11:15 AM

Are you using the directx utility library?

If you are you may need to tweak the viewing frustrum. It seems to me the default front clipping plane is set to far from the screen.

Hope I helped.

#3 Jeff K   Members   -  Reputation: 122

Like
Likes
Like

Posted 19 January 2000 - 10:03 AM

Apparently you''re zooming by moving the camera forward.
Try keeping the camera still and reducing the field of view.

#4 Goodlife   Members   -  Reputation: 122

Like
Likes
Like

Posted 19 January 2000 - 11:55 PM

Well, I zoom by changing the scale factor on the view projection. I thought this would prevent things from getting behind the camera.

I don''t move the camera at all.

#5 Jeff K   Members   -  Reputation: 122

Like
Likes
Like

Posted 20 January 2000 - 10:50 AM

Ah. Then you should change your near and far clipping planes along with the scale.

#6 Pseudo   Members   -  Reputation: 100

Like
Likes
Like

Posted 21 January 2000 - 09:42 AM

scaling the view matrix isn''t the best way to do it, this just basicaly inlarges everything, and that makes it come too close to the camera. I suggest looking into the details on setting up a projection matrix that has a variable viewing angle, then if you want to zoom, you just decrease the angle, and reset the matrix.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS