Jump to content

  • Log In with Google      Sign In   
  • Create Account

Picking / glRenderMode(GL_SELECT)


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
3 replies to this topic

#1 Hedin   Members   -  Reputation: 122

Like
Likes
Like

Posted 26 December 2001 - 10:57 AM

Hi I’m having a rather annoying problem with my picking implementation. I’ve done more or less as the documentation and the NeHe tutorial on the subject says and everything works fine when I run the app in a window. But when switching to fullscreen it takes forever, 0.5s to 0.7s, for OpenGL to “render” (nothing is being rendered since I’m running in glRenderMode(GL_SELECT)) the object being picked. I’ve done tests with over a hundred objects and it’s just the picked object that is causing the huge render time. I appreciate any help or hints I can get on this one, I have a 16Mb Voodoo 3000.

Sponsor:

#2 Hedin   Members   -  Reputation: 122

Like
Likes
Like

Posted 03 January 2002 - 07:43 AM

Thanks for all the answers

Now I have installed a Geforce2 MX instead and picking works fine... but now I''m having problems with RTCW... don''t you just love computers?


#3 Dredge-Master   Members   -  Reputation: 175

Like
Likes
Like

Posted 05 January 2002 - 05:03 AM

you are probably already doing this, but draw everything as a flat quad instead of shaded textured quads and get rid of all the lighting and stuff if you are using it whilst doing the pick call. It helps speed it up as it doesn''t have to draw as much, and it doesn''t really care if it is textured or not.

#4 Hedin   Members   -  Reputation: 122

Like
Likes
Like

Posted 05 January 2002 - 05:27 AM

Yes I am but thanks any way!




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS