Jump to content

  • Log In with Google      Sign In   
  • Create Account

We're offering banner ads on our site from just $5!

1. Details HERE. 2. GDNet+ Subscriptions HERE. 3. Ad upload HERE.


Should I use Winsock 1.1?


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
1 reply to this topic

#1 Demitri   Members   -  Reputation: 122

Like
Likes
Like

Posted 30 January 2000 - 07:56 AM

I am going to write a very simple graphical online RPG. Aimed at around 10 or so users. I will probably use TCP/IP (since it''s this small, this should be perfect, right?) instead of UDP. Anyways, Winsock 1.1 contains everything for using TCP/IP, so it should suffice perfectly, right? That way, also clients with win95 who do not have the winsock 2.0 update should be able to use my program. So.. Winsock 1.1 should be fine, right? Tim

Sponsor:

#2 SiCrane   Moderators   -  Reputation: 9629

Like
Likes
Like

Posted 30 January 2000 - 02:38 PM

Winsock 1.1 should be fine. Just remember that multi-threaded implementations should use the select statement rather than WSAAsyncSelect. (In Winsock 2.0 you''d use WSAEventSelct.)




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS