Jump to content

  • Log In with Google      Sign In   
  • Create Account

FREE SOFTWARE GIVEAWAY

We have 4 x Pro Licences (valued at $59 each) for 2d modular animation software Spriter to give away in this Thursday's GDNet Direct email newsletter.


Read more in this forum topic or make sure you're signed up (from the right-hand sidebar on the homepage) and read Thursday's newsletter to get in the running!


Why does it slow down?


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
5 replies to this topic

#1 Esap1   Members   -  Reputation: 122

Like
Likes
Like

Posted 09 February 2000 - 06:58 PM

Here is something I dont understand(whats new). In my game, when the viewer is far from any walls it runs really fast, even if all the polygons are on the screen, yet, If I face a direction with only 1 Polygon on the screen and it is close to the screen and takes up the whole screen, the fps shoots down to 45fps, from 95, whats up wit dat? PLEASE, I need help!!!!! Please, any help, THANK YOU!(is it clipping?)

Sponsor:

#2 trixter   Members   -  Reputation: 122

Like
Likes
Like

Posted 10 February 2000 - 02:22 AM

how are you handling your world polys? seems like you are rendering a bunch of stuff behind the wall too. does it get slower as you get closer to the walls or is it a sudden jump? if it''s gradually then it can be your fillrate since it takes more fillrate to render larger polys on screen than smaller ones.

hard to tell with just the info you gave.

#3 Spellbound   Members   -  Reputation: 122

Like
Likes
Like

Posted 10 February 2000 - 03:01 AM

Don''t know what type of hardware you got, but I remember that the Voodoo2 (and 1 for that matter) is extremely slow if you render outside the visible screen. Do you clip your polygons correctly?

#4 Esap1   Members   -  Reputation: 122

Like
Likes
Like

Posted 11 February 2000 - 06:37 PM

Here, Im running with 2 Voodoo2 SLI, And I tried it with just a 4 polys, like a room with no ceiling or floor, and with no textures, Im using DX7, and the helper functions, I was hoping it was doing the 2d clipping for me, any help??

#5 Facehat   Members   -  Reputation: 696

Like
Likes
Like

Posted 12 February 2000 - 02:55 AM

It''s probably a fill rate problem. When you have one giant polygon on there it''s going to be a bit slower in filling it since it has to filter the whole thing etc.

--TheGoop

#6 paulcoz   Members   -  Reputation: 230

Like
Likes
Like

Posted 15 February 2000 - 08:41 PM

Just wanted to comment I am running the same setup - eg. Voodoo2s in SLI - I doubt it is the fill-rate. My program is written in Glide and I have about 5 objects in the world - if I walk up close (and even through the walls) there is absolutely no slow down whatsoever, actually the same goes for Unreal which is a little more advanced than my program.

I don''t know if you do things the same with DirectX but using Glide you definitely have to do 2d-clipping - otherwise it doesn''t just slow down, it hangs bigtime.

Paulcoz.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS