Jump to content

  • Log In with Google      Sign In   
  • Create Account

Quake 2 cooperative mode: can friendly fire turn off?


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
6 replies to this topic

#1 sporty   Members   -  Reputation: 122

Posted 21 May 2002 - 10:35 AM

Me and a bunch of local friends feel like getting back to our gaming "roots", just for fun, and we''ve started deathmatching in Quake/Quake2 heavily lately. We want to play some cooperative Quake2 though, and we do, but the problem is the friendly fire. It''s such a pain in the ass when we accidentally hit each other in the line of fire.. This mode can easily be turned off in Quake 1 cooperative and deathmatch, and it can be turned off in Q2 deathmatch as well, but the command "dmflags" (in which this setting is stored) is disabled in Q2 Coop. Is there anyway at all to turn off friendly fire in Q2 cooperative? I cannot imagine why id would not include that feature..

Sponsor:

#2 Quantum   Members   -  Reputation: 122

Posted 21 May 2002 - 11:35 AM

Yes...I''m fairly sure... it''s been a while.

Try setting everyones model and skin to the same thing.

If that doesn''t work try typing dmflags 16776 at the console.

#3 sporty   Members   -  Reputation: 122

Posted 21 May 2002 - 11:43 AM

quote:
Original post by Quantum
Try setting everyones model and skin to the same thing.



Yeah, we tried that a number of times, to no success.

quote:

If that doesn''t work try typing dmflags 16776 at the console.


Like I said in first post, the dmflags variable is disabled in the cooperative mode. Why? Nobody knows.



#4 granat   Members   -  Reputation: 122

Posted 21 May 2002 - 12:23 PM

Only sissies who do not like Starwars turn off friendly fire hrrrmpf

#5 sporty   Members   -  Reputation: 122

Posted 21 May 2002 - 12:26 PM

quote:
Original post by granat
Only sissies who do not like Starwars turn off friendly fire hrrrmpf


Behehe..who says I don''t like Starwars? I love the series!

If you''re referring to that other thread, I was just making an example of how you can reduce any movie to stupid critiques.

#6 granat   Members   -  Reputation: 122

Posted 21 May 2002 - 09:36 PM

I was referring to the other thread. Good to hear that you have good taste after all

#7 Quantum   Members   -  Reputation: 122

Posted 21 May 2002 - 11:57 PM

Just had a look in the source. Found this:

  
// friendly fire avoidance

// if enabled you can''t hurt teammates (but you can hurt yourself)

// knockback still occurs

if ((targ != attacker) && ((deathmatch->value && ((int)(dmflags->value) & (DF_MODELTEAMS | DF_SKINTEAMS))) || coop->value))
{
if (OnSameTeam (targ, attacker))
{
if ((int)(dmflags->value) & DF_NO_FRIENDLY_FIRE)
damage = 0;


Notice
a) the coop->value at the end of the if
b) the OnSameTeam check and
c) the dmflags->value check

So, you''ll need to:
Make sure "coop" is "1" (obviously)
Make sure all models/skins are the same (type skin "male/grunt")
Set dmflags! Even though it says in the menu N/A for coop, I''ve just tested and dmflags do work in coop. Type dmflags 16776 in the console or go into create game, set it to deathmatch and work out the correct flags.

Ok, so I don''t exactly have any one to test this with, but I seem to remember playing Quake2 coop w/o FF. Sorry if what I''ve said is completely obvious, stupid, doesn''t work, etc. I havn''t played Q2 for a long while.
Hope this helps, anyway.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS