I think it's a good practice to do so.
I prefix stuff like CTextureManager, it is quite neat.
But when it comes to classes like
AStar, I feel very strange to have such a letter as the prefix...
I don't like to call it CAStar, which is very windy...