Looks pretty good to me.
Changing the if/elseif to a switch statement in this case is unnessary. It would totally be a case of premature optimization and only make the code slightly less readable.
The only thing I'd say... for the sake of learning code, avoid using the Array.Reverse() method and try to do it manually.
Also: what happens if someone wants to print their names -1 times?