Jump to content

  • Log In with Google      Sign In   
  • Create Account


Member Since 05 May 2008
Offline Last Active Apr 14 2012 08:15 PM

Posts I've Made

In Topic: Loading Textures with SOIL?

14 April 2012 - 08:20 PM

From what I understand of SOIL, I was loading the same texture but with two different methods (generating mipmaps for one, not for the other two). It is just laid out that way so I have an easier time staring at it trying to figure out what was wrong.

In Topic: Lesson 10: Texturing issue

14 April 2012 - 08:19 PM

I'm loading it all from the world file given in the sample:
float x, y, z, u, v;
int tris;
char textline[255];
FILE *filein = fopen( "Assets/Worlds/World.txt", "rt");
ReadStr( filein, textline );
sscanf( textline, "NUMPOLLIES %d\n", &tris);
sector1.numTriangles = tris;
sector1.triangles = new triangle[sector1.numTriangles];
for ( int triangles = 0 ; triangles < sector1.numTriangles ; triangles++ )
  for ( int vert = 0 ; vert < 3 ; vert++ )
   ReadStr(filein, textline);
   sscanf(textline, "%f %f %f %f %f", &x, &y, &z, &u, &v);
   sector1.triangles[triangles].vertices[vert].x = x ;
   sector1.triangles[triangles].vertices[vert].y = y ;
   sector1.triangles[triangles].vertices[vert].z = z ;
   sector1.triangles[triangles].vertices[vert].u = u ;
   sector1.triangles[triangles].vertices[vert].v = v ;

It looked fine when stepping through the code, and I pretty much copy/pasted the tutorial project into mine with the modified texture loading and got the same result which is why I believe it has something to do with misusing SOIL.

In Topic: What do I need to include to use timeSetEvent?

16 December 2009 - 06:36 PM

Thanks for pointing that out, but I'm still getting that damn unresolved external.

In Topic: What do I need to include to use timeSetEvent?

16 December 2009 - 06:24 PM

Guess I'll post more problem since no one is looking yet:

1>Profiler.obj : error LNK2019: unresolved external symbol __imp__timeSetEvent@20 referenced in function "public: void __thiscall Profiler::Initialize(void)" (?Initialize@Profiler@@QAEXXZ)
1>D:\Documents\Project\Debug\Project.exe : fatal error LNK1120: 1 unresolved externals

Soooooooooooooooo, I have no idea what the hell is wrong. I see a few examples, but they're only including windows.h, process.h, and stdio.h all of which I'm including. What gives?

In Topic: Looping through a std::set and accessing the data?

16 November 2009 - 06:25 PM

I swear it was giving me compilation errors with the increment operator....