Jump to content

  • Log In with Google      Sign In   
  • Create Account

We're offering banner ads on our site from just $5!

1. Details HERE. 2. GDNet+ Subscriptions HERE. 3. Ad upload HERE.


Don't forget to read Tuesday's email newsletter for your chance to win a free copy of Construct 2!


officialhopsof

Member Since 29 Oct 2008
Offline Last Active Aug 11 2013 07:44 PM

Topics I've Started

Writer Wanted: Mobile Adventure-Comedy Game

11 August 2013 - 07:16 PM

I am looking for a writer [deleted]


Ortho Pixel, possibly Point Sprite?

25 August 2009 - 05:26 AM

Basically, I have a 3d world, and I need to place a single pixel at a location in this 3d world. Whenever the camera looks at the point, I need the pixel to be visible, regardless of its distance from the viewer. I tried just drawing a sphere, but as it gets farther away it gets smaller (as it should). Eventually it gets so small it is no longer drawn, which again, makes perfect sense. But I need to be able to see at least one pixel of this sphere at all times. I am not using OpenGL directly, but am using a Visualization package (vega prime) that uses OpenGL under the hood, which I am able to gain access to. I am also not very well versed in how OpenGL works and as such would very much consider myself a novice of it. I am developing on Windows XP with both CodeBlocks (with mingw) and with VC++ 2003. If you could show me just a very minimalistic example of how to do this, I would be very grateful. Just something like showing me a single drawing routine (like from glBegin() and glEnd()) would be best. The visualization package takes care of all the windows nonsense for me. Thank you very much for your time and help, Brandon Murphy

Faces not showing up

04 November 2008 - 03:24 AM

I have this situation: Fill and in wirefram: Wireframe Now, as you can see, in the filled one, there are holes showing up, but in the wire frame one, everything seems like it should be. I have face culling disabled, and I am using:
glEnable(GL_DEPTH_TEST);
glDepthFunc(GL_LESS);



does anyone know what may be going wrong here? Just a nudge in the right direction would be fantastic. Thank you, Brandon

Object missing faces

29 October 2008 - 12:34 PM

I have this situation:

glBegin(GL_QUADS); // Draw The Cube Using quads
glColor3f(0.0f,1.0f,0.0f); // Color Blue
glVertex3f( 1.0f, 1.0f,-1.0f); // Top Right Of The Quad (Top)
glVertex3f(-1.0f, 1.0f,-1.0f); // Top Left Of The Quad (Top)
glVertex3f(-1.0f, 1.0f, 1.0f); // Bottom Left Of The Quad (Top)
glVertex3f( 1.0f, 1.0f, 1.0f); // Bottom Right Of The Quad (Top)
glColor3f(1.0f,0.5f,0.0f); // Color Orange
glVertex3f( 1.0f,-1.0f, 1.0f); // Top Right Of The Quad (Bottom)
glVertex3f(-1.0f,-1.0f, 1.0f); // Top Left Of The Quad (Bottom)
glVertex3f(-1.0f,-1.0f,-1.0f); // Bottom Left Of The Quad (Bottom)
glVertex3f( 1.0f,-1.0f,-1.0f); // Bottom Right Of The Quad (Bottom)
glColor3f(1.0f,0.0f,0.0f); // Color Red
glVertex3f( 1.0f, 1.0f, 1.0f); // Top Right Of The Quad (Front)
glVertex3f(-1.0f, 1.0f, 1.0f); // Top Left Of The Quad (Front)
glVertex3f(-1.0f,-1.0f, 1.0f); // Bottom Left Of The Quad (Front)
glVertex3f( 1.0f,-1.0f, 1.0f); // Bottom Right Of The Quad (Front)
glColor3f(1.0f,1.0f,0.0f); // Color Yellow
glVertex3f( 1.0f,-1.0f,-1.0f); // Top Right Of The Quad (Back)
glVertex3f(-1.0f,-1.0f,-1.0f); // Top Left Of The Quad (Back)
glVertex3f(-1.0f, 1.0f,-1.0f); // Bottom Left Of The Quad (Back)
glVertex3f( 1.0f, 1.0f,-1.0f); // Bottom Right Of The Quad (Back)
glColor3f(0.0f,0.0f,1.0f); // Color Blue
glVertex3f(-1.0f, 1.0f, 1.0f); // Top Right Of The Quad (Left)
glVertex3f(-1.0f, 1.0f,-1.0f); // Top Left Of The Quad (Left)
glVertex3f(-1.0f,-1.0f,-1.0f); // Bottom Left Of The Quad (Left)
glVertex3f(-1.0f,-1.0f, 1.0f); // Bottom Right Of The Quad (Left)
glColor3f(1.0f,0.0f,1.0f); // Color Violet
glVertex3f( 1.0f, 1.0f,-1.0f); // Top Right Of The Quad (Right)
glVertex3f( 1.0f, 1.0f, 1.0f); // Top Left Of The Quad (Right)
glVertex3f( 1.0f,-1.0f, 1.0f); // Bottom Left Of The Quad (Right)
glVertex3f( 1.0f,-1.0f,-1.0f); // Bottom Right Of The Quad (Right)
glEnd(); // End Drawing The Cube

*are there not [code=auto:0] blocks on this forum? I cant seem to find it

well as you can see, if you draw that, the front face is missing, and you see the inside of the cube. How can i correct this error?

Thank you

PARTNERS