Jump to content

  • Log In with Google      Sign In   
  • Create Account

Banner advertising on our site currently available from just $5!


1. Learn about the promo. 2. Sign up for GDNet+. 3. Set up your advert!


Zervoxe

Member Since 28 Aug 2009
Offline Last Active Yesterday, 11:33 AM

Posts I've Made

In Topic: Angelscript Operators

04 January 2015 - 02:20 AM

I didn't really need help on how to write the dump, but thanks for the gesture. :)

I just don't agree on having a singular method for exposing it, difference of opinion is all. :)


In Topic: Angelscript Operators

03 January 2015 - 11:25 AM

Dumping the API as in your test_dump, I am using that test to dump all exposed classes in C++ instead of having to write documentation wrappers around the register methods.

but the dumped code will write the operators and behaviors as

 

_beh(number

opEqual

opCmp 

opAddAssign

once

 

for any other language these operators are written explicitly as

function name()
==
!=
<=
>=
+=

What I am doing is converting opAddAssign to += in the output file instead because they are universal through all languages

 

you would write

object.opAddAssign(input);

but 

object += input;

as it is more readable. hence to document my exposed scripting objects,enums,behaviors I dump all C++ api inputs to different text files.

so for dumping opCmp

I would have to do

Write(replace(string,"opCmp",'<'))
Write(replace(string,"opCmp",'<='))
Write(replace(string,"opCmp",'>'))
Write(replace(string,"opCmp",'>='))

In Topic: Angelscript Operators

03 January 2015 - 03:52 AM

I meant there is no difference between opCmp and opEqual when dumping the API, but as I also said, no worries I will just iterate and export it twice over with different string values.


In Topic: Angelscript Operators

02 January 2015 - 10:54 AM

When dumping the API it adds opEqual and opCmp and there is no difference for them, I am using it to export the documentation, I guess I could just in the case it finds opEqual or opCmp run fixed iterations for each of them.

so that I have

+=

+

instead of 

opAddAssign

opAdd

Not really a huge problem, it was just a suggestion. : )


In Topic: Global Property Singleton

31 December 2014 - 12:13 PM

r = engine->RegisterObjectMethod("MyClass", "const string name() const", asMETHOD(MyClass, get_name), asCALL_THISCALL); assert(r >= 0);

shouldn't this be

r = engine->RegisterObjectMethod("MyClass", "const string &name() const", asMETHOD(MyClass, get_name), asCALL_THISCALL); assert(r >= 0);

like in your C++ class?


PARTNERS