Jump to content

  • Log In with Google      Sign In   
  • Create Account


Member Since 16 Jan 2011
Online Last Active Today, 09:47 AM

Posts I've Made

In Topic: D3D11CreateDevice freeze

Today, 05:55 AM

If you pass in the debug flag when creating the device do you get any warning/error messages?

It freezes with and without that flag.

BTW. It also happens with glChosePixelFormat (a bit rearely I suppose).


I will change my driver (upgrade or downgrade).

You may need to add your executable to the 3D graphics list in the Nvidia driver and force it to use dedicated graphics for the 960M.

I'll give it a try thanks!

In Topic: "Supply depots" for medieval game?

Today, 01:26 AM


In Topic: Use which kind of generic string?

02 May 2016 - 01:12 PM

Currently we store our string internally as UTF8 and we do operations between UTF8 strings. The cool thing about UTF8 is that they work perfectly with std::string(or in out cause a lagacy string class that was implemented around char*) (as the 0 will be found only at the end of the file).
Under windows we convert to UNICODE/MBCS when needed(example is winapi specific function as OpenFile, SendMessage, CreateWindow...)
The unix based platforms already use utf8 as a native string.


Actually a good starting point would be to do what the guys form Autodesk Maya do with their MString (see MString::asChar method(it returns the string value in a platform native format)). 

BTW a side hint:
In the MSVS  in the debugger's watch windows if you type "mystringVariable, s8" the value of "mystringVariable" is going to be display as UTF8 string an not as a MBCS string ^_^

In Topic: Best Laptop for Game Development and Programming?

26 April 2016 - 03:16 PM

@imoogiBG How  "carry-friendly" is this ROG you bought? Is it heavy to carry around for a few hours?

It's kind of heavy-ish, but i think it's not going to be a problem.


EDIT: yes it is ROG with aluminium screen shield(it was probably a mistake as I gave 50EUR for that shield).

In Topic: Where to learn 2D Math for game dev

26 April 2016 - 04:33 AM

Just learn linear algebra and analytic gemetry (not sure if thats how you call it in english).

Both are really sumple, just take a bit time to master it. After you learn those things you will know what to learn next.

Additionally learn calculus :)