Jump to content

  • Log In with Google      Sign In   
  • Create Account

codewill

Member Since 29 Mar 2011
Offline Last Active Jan 11 2013 10:55 PM

Topics I've Started

Set alpha channel in pixel Bliting.

07 January 2013 - 12:33 AM

In Bink video how to eliminate the black pixel setting the Alpha =0 during at playback time?

 

In Allegro5 I set a Background image and create a popup new window where I show a .bik video.

This .bik video has black backgroud and has not Alpha Channel when the frame is decompressed.

I need set transparency where black pixel appear. So the main window background can be visible.

I have the RAD SDK.

 

In a call to Blit_RAD_3D_image (Blit a 3D image onto the render target) I have this:

      if ( rad_image->download_textures )
      {
        Submit_texture( pixels,
                        rad_image->row_length,
                        rad_image->maximum_texture_size,
                        rad_image->maximum_texture_size,
                        rad_image->gl_surface_type );
      }

      //
      // Submit the vertices.
      //

      Submit_vertices( dest_x,
                       dest_y,
                       x_scale,
                       y_scale,
                       rad_image->maximum_texture_size,
                       rad_image->maximum_texture_size,
                       alpha_level,
                       is_premultiplied_alpha );

 

 

VS2010 C++.

 

Thank you.

 

Set up Transparency in Bink video.

05 January 2013 - 10:05 PM

I have a Bink video file with Transparency Alpha Channel.

 

When playback the video the area with transparency is shown black.

 

How I set up the Bink Api for transparency?

 

Using VS2010 C++.

 

Thank you.


PARTNERS