Jump to content

  • Log In with Google      Sign In   
  • Create Account

We're offering banner ads on our site from just $5!

1. Details HERE. 2. GDNet+ Subscriptions HERE. 3. Ad upload HERE.


GDsnakes

Member Since 04 Aug 2011
Offline Last Active Apr 10 2013 09:42 AM

Posts I've Made

In Topic: I need help with SDL/OPENGL Color Keying.....

22 March 2013 - 07:32 AM

I'm having a weird problem, whenever I set Uint32 colorkey = SDL_MapRGB(surface, 255, 255, 255); It turns every geometric object I have draw using Opengl black.

 

If I set Uint32 colorkey = SDL_MapRGB(surface, 255, 255, 254); and RGB aren't all 255 then its fine, but that a problem since I'm trying to remove a white background. So why would Uint32 colorkey = SDL_MapRGB(surface, 255, 255, 255); be making all of my previously drawn shapes black?


In Topic: I need help with SDL/OPENGL Color Keying.....

21 March 2013 - 06:10 AM

Anyone?


In Topic: Texture wont show on quad.

13 February 2013 - 05:19 PM

The code works as it is for me. Check for OpenGL errors in your code.

The image shows on screen for you? How can that be?


In Topic: Problem with creating a class for drawing....

17 January 2013 - 06:35 PM

Fixed it. Needed to Swap Buffers.


In Topic: Problem with creating a class for drawing....

17 January 2013 - 04:24 PM

One kind of obvious thing that jumps at me is your constructor. Take a good look at it and if you don't notice it, describe to me in detail what it does ,-)

Trienco that looks like it might be why it doesn't work.

 

GDsnakes you should make all function inputs const unless you have to modify it.

I changed it to this. Still the exact same same issues.

 

QuadDrawing::QuadDrawing( float Xoff, float Yoff)
{
QuadoffX = Xoff;
QuadoffY = Yoff;
}

PARTNERS