Jump to content

  • Log In with Google      Sign In   
  • Create Account

FREE SOFTWARE GIVEAWAY

We have 4 x Pro Licences (valued at $59 each) for 2d modular animation software Spriter to give away in this Thursday's GDNet Direct email newsletter.


Read more in this forum topic or make sure you're signed up (from the right-hand sidebar on the homepage) and read Thursday's newsletter to get in the running!


he3117

Member Since 29 Nov 2011
Offline Last Active Sep 20 2014 03:28 PM

Posts I've Made

In Topic: physx vehicle problem

14 May 2013 - 06:36 AM

Solved.

I forgot to put the vehicle in rest state before adding it to scene.


In Topic: Can you guess what is leaking?

31 March 2013 - 04:44 AM

May be you forgot to delete the bone name.

In Topic: Crash on exit

26 January 2013 - 02:32 AM

maybe m_pRenderTargetView and swap chain are the same before the shutdown.


In Topic: Unable to get depth working in 2D engine

16 January 2013 - 01:59 AM

I'm working with DX9 and my answer may not help you so much but check the return value of ClearDepthStencilView.

In dx9 this function can fail if you don't have stencil information in depth buffer.


In Topic: Incorrect directional lighting when rotating

28 December 2012 - 02:38 AM

Hi

I had exactly the same problem.I tracked the normal transform and I found the problem.

for me changing :

 

output.Normal =mul(input.Normal,World);

to

output.Normal =mul(World,input.Normal);

 

solved it or you can transpose the world matrix before multiply it.


PARTNERS