Jump to content

  • Log In with Google      Sign In   
  • Create Account

danothom

Member Since 27 Apr 2012
Offline Last Active May 02 2012 04:31 PM

Topics I've Started

The SDL, TTF_Init() and Truetype Saga...

27 April 2012 - 10:15 AM

Hi,

I'm really hoping that someone can help me sort out this issue I'm having.

-- info --
[Using Win7 64 with Visual C++ Express. ]
[SDL and OpenGL are working fine.]
[The VC10 environment and Linker files are all correct and I've linked SDL_ttf.dll as well as copied the relevant files to the debug directory in line with the other SDL APIs etc]

A few months ago I embarked on a mission to both learn C++ and build a game. I've got quite far but have recently hit a brick wall with getting TTF and TrueType to work. I'm writing this request as a last hope, I've fiddled, compiled, read docs, searched the net and this forum extensively to no avail.

This issue all started when TTF_Init() returns -1 religiously. After some exploration it appears that I needed TrueType.
I'm OK on the technical side of things but for the life of me I can't get Truetype installed correctly. I've downloaded the latest version and didnt really figure out exactly how to correctly utilized the files the archive contained.

I eventually managed to get a GNU Make tool compiled, but when I try and run the "make.exe" on the TrueType "makefile" file it gives me a "'gcc' is not recognized as an internal or external command" error. I've used "make clean" and I've tried a few other compiler builds, however I'm fairly certain that the vcc build is the correct one in this case.

I know I'm meandering on but here are a few of my questions that I'd really appreciate some insight on.

1.) Please can someone detail the steps they used to get TrueType installed on Win7 64 environment !?

2.) I've managed to build the freetype248.lib Library file, but Im pretty sure its the accompanying DLL which Im missing, and thats where the whole makefile process comes in.

3.) Do I need to then add freetype248.lib to the Linker?

4.) Do I need to also set up the Include to link to the truetype include folder?

Why is this so complex?! Also - I've googled the hell out of this issue for the last 2 days and can't find much useful info on my issue. It makes me feel retarded like Im missing something simple here.

Apologies for the long query - any insight would be miuch appreciated!!

PARTNERS