Jump to content

  • Log In with Google      Sign In   
  • Create Account


Syncan

Member Since 16 Jun 2012
Offline Last Active Jun 18 2012 08:55 AM
-----

Topics I've Started

compatibility-problem with older .NET versions in Windows 8

16 June 2012 - 09:24 AM

Since a month I am learning to write games, using the book "Learn VB .NET through Game Programming" from Matt Tagliaferri.
The examples also include working with DirectX and those work fine in Windows XP.

I have the try-out version of Windows 8, and I installed Visual Basic 2010 Express, with the intention to see if I can run the same examples from Windows XP.
Sofar it is not working, simply because I cannot get the older .NET-versions installed which the book uses.
I need the .NET versions 3.0 and 3.5 but Windows 8 simply refuses to install it.

When I try to run the DirectX - examples on .NET 4.0 I get the following error:

A first chance exception of type 'Microsoft.DirectX.DirectDraw.UnsupportedException' occured in Microsoft.DirectX.DirectDraw.dll

... which says me you really need the older .NET version as some functions are not supported anymore with .NET 4.0
The error was on the following line:

Fdraw.SetDisplayMode ( WID, HGT, 16. 0, False )


Can somebody help me out? Thank you.Posted Image

PARTNERS