I also wouldn't recommend using i as the for loop counter as well as the int pointer returned from new. (It's legal, since the for loop i hides the int* i in the scope of the for loop, but bad style).
Lower case L is a bad name for a variable too (especially with this font), it looks too much like capital I, vertical bar | or 1.
INT_FUNCTION in all capitals isn't the best style either; most people use all caps for #defines, constants, or struct names (in which case INT_FUNCTION() could be the default constructor, I suppose, but its name suggests to me it is a function).
Good style is important it promotes readability and indicates the intent of code to others.
Hi yes i know, I was just something i type to show case my problem.. thx for the feedback though.