Jump to content

  • Log In with Google      Sign In   
  • Create Account

turtle64

Member Since 04 Aug 2012
Offline Last Active Aug 04 2012 04:39 PM

Topics I've Started

Trying to get a start in OpenGL but keep hitting bumps in the road.

04 August 2012 - 02:48 PM

Hey I've just about finished the second chapter of Luke Bensteads book "Beginning OpenGL Game Programming 2nd edition" and when it comes down to compiling the code I've typed along with his example code, I keep getting a LNK2019 Error

1>------ Build started: Project: OpenGLHellowWorld, Configuration: Debug Win32 ------
1>Build started 8/4/2012 4:39:19 PM.
1>InitializeBuildStatus:
1>  Touching "Debug\OpenGLHellowWorld.unsuccessfulbuild".
1>ClCompile:
1>  main.cpp
1>GLWindow.obj : error LNK2019: unresolved external symbol "private: void __thiscall GLWindow::setupPixelFormat(void)" (?setupPixelFormat@GLWindow@@AAEXXZ) referenced in function "public: long __stdcall GLWindow::WndProc(struct HWND__ *,unsigned int,unsigned int,long)" (?WndProc@GLWindow@@QAGJPAUHWND__@@IIJ@Z)
1>main.obj : error LNK2019: unresolved external symbol "public: float __thiscall GLWindow::getElapsedSeconds(void)" (?getElapsedSeconds@GLWindow@@QAEMXZ) referenced in function _WinMain@16
1>main.obj : error LNK2019: unresolved external symbol "public: bool __thiscall GLWindow::isRunning(void)" (?isRunning@GLWindow@@QAE_NXZ) referenced in function _WinMain@16
1>main.obj : error LNK2019: unresolved external symbol "public: void __thiscall GLWindow::destroy(void)" (?destroy@GLWindow@@QAEXXZ) referenced in function _WinMain@16
1>main.obj : error LNK2019: unresolved external symbol "public: void __thiscall GLWindow::attachExample(class Example *)" (?attachExample@GLWindow@@QAEXPAVExample@@@Z) referenced in function _WinMain@16
1>C:\Users\Owner\Desktop\DirectXProjects\OpenGLHellowWorld\Debug\OpenGLHellowWorld.exe : fatal error LNK1120: 5 unresolved externals
1>
1>Build FAILED.
1>
1>Time Elapsed 00:00:00.48
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

I've looked around the internets for the solution to this problem but to no avail. Alls I could find was setting your sub-system in the Linker settings to Windows. I've already had it set to windows and switching it to anything else but windows will tack on an extra unresolved external error. Anyone have any clues?

PARTNERS