Jump to content

  • Log In with Google      Sign In   
  • Create Account

Knut

Member Since 04 Sep 2012
Offline Last Active Sep 11 2012 02:28 PM

Topics I've Started

Ortho texture issue

10 September 2012 - 02:28 PM

Hi all,

I am trying to render a textured quad in ortho mode. When I render it as a rectangle, it works fine, as this picture shows:
Posted Image

However, when I try to move one corner half way to the center, the texture gets weirdly skeeved:
Posted Image

Notice the red line going up. I would think that it should be sloped towards the upper right corner, but it's rendered straight up. Is this normal?
There is only one textured quad in this picture, rendered using fixed function pipeline. The texture coords are all either 0 or 1 in the corners. Why is the texture rendered like this?

Thanks in advance.
Knut

SOLVED: Problem with gluProject

04 September 2012 - 12:47 PM

Hi guys,
I'm having some trouble with gluProject. I'm working on a small game, and I need the user to be able to click on entities and get information etc about them. To archieve this, I have been trying to mix 3d graphics (for the entities) with 2d graphics (for the GUI parts). The entities are rendered in perspective mode, while the GUI parts are rendered in ortho mode.
When rendering the entities, the model-view matrix is set according to the camera position and rotation, and passed to the shaders. For each model, the models position and rotation is also passed to the shader separately.
So to archieve things like selection marker, I have been using gluProject. The projection and view-port matrices are stored in the beginning of the program execution, and the model-view matrix is stored during each frame. The matrices are read from OpenGL itself. They are all used in this method:
[source lang="java"] /* * (non-Javadoc) * @see no.bog.starship.services.Renderer#project(no.bog.starship.glutil.GLVector) */ @Override public GLVector project(GLVector worldSpaceVector) { GLU.gluProject(worldSpaceVector.x, worldSpaceVector.y, worldSpaceVector.z, this.mvMatrixBuffer, this.projectionMatrixBuffer, this.viewPortMatrixBuffer, this.screenPositionBuffer); GLVector rc = new GLVector(new float[]{this.screenPositionBuffer.get(), this.screenPositionBuffer.get(), this.screenPositionBuffer.get()}); this.screenPositionBuffer.rewind(); return rc; }[/source]

To switch between 3D and 2D mode, I have these functions, which are called before rendering:
[source lang="java"] /** * Prepare for 3D rendering. */ protected void prepare3D() { GL11.glMatrixMode(GL11.GL_PROJECTION); GL11.glLoadIdentity(); GLU.gluPerspective( 45.0f, (float) this.windowWidth / (float) this.windowHeight, 1.0f, 1000.0f); GL11.glMatrixMode(GL11.GL_MODELVIEW); GL11.glLoadIdentity(); } /** * Prepare for 2D rendering. */ protected void prepare2D() { //Prepare projection matrix to render in 2D GL11.glMatrixMode(GL11.GL_PROJECTION); GL11.glLoadIdentity(); // clear the perspective matrix GL11.glOrtho( // turn on 2D mode 0, this.windowWidth, // left, right 0, this.windowHeight, // bottom, top -1, 1); // Zfar, Znear //Prepare the modelview matrix GL11.glMatrixMode(GL11.GL_MODELVIEW); GL11.glLoadIdentity(); //Clear the Modelview Matrix }[/source]
When using this, I have managed to create some selection markers, which I have simply implemented as quads with a texture aligned next to the model, as you can see in this picture. These quads are all rendered with z-value set to zero. (In other words, I am using gluProject to simply find the x and y coordinates to use).
I am now trying to add a feature where the user is shown a "map" around the selected entity (think move range or something like this). I want to draw it in ortho so the texture on it is not distorted by perspective. However, I am having trouble when I try to use gluProject to do this. I am trying to add a simple quad with the same y-coord as the entity and the x and z set to +/- 10...but the values returned by gluProject does not make sence to me...it seems the center of this quad is not in the same position as the entity (a simple cube in 0,0,0), especially when the camera is close to 0,0,0.
Can anyone tell me what I need to do with the z value to be able to use it?
I am thinking of rendering with depth test...will this work?
Is there any other way of rendering these kinds of things which are easier/nicer?
Thank you in advance

PARTNERS