Jump to content

  • Log In with Google      Sign In   
  • Create Account


grasshop

Member Since 07 Sep 2012
Offline Last Active Private

Posts I've Made

In Topic: SwapBuffers issue

27 May 2013 - 07:08 AM

Ok I've found out what changed on my system. It's because I turned off Vista Aero that this started to happen. Turning it back on it works properly. So what is it about Aero being off that makes it work differently?

 

EDIT: More specifically it is the "enable desktop composition" effect.


In Topic: Texture Interpolation Problem With Transparent Pixels

09 September 2012 - 04:19 PM

Ok, thanks for the help. I think at this point anyway it will be better to just have the user sort their own images out, that seems to be what some other game making environment just do. I guess it's not that big or common a problem.

In Topic: Texture Interpolation Problem With Transparent Pixels

09 September 2012 - 05:36 AM

The problem is I don't actually have any control over anything myself as I am working on a user game development environment and the user could use any textures themselves and call upon any blend functions as well to that matter. I ask about DirectX because this problem doesn't occur in another game development environment which I am actually trying to emulate and it uses DirectX instead of OpenGL. I'm wondering how on earth the guy that wrote that managed to resolve this issue nicely.

I apologise for not giving the full circumstances before I was trying not to complicate things.

In Topic: Texture Interpolation Problem With Transparent Pixels

09 September 2012 - 04:27 AM

Can I just ask, does DirectX suffer from this same issue?

In Topic: Texture Interpolation Problem With Transparent Pixels

08 September 2012 - 11:39 PM

Thanks for the info. Is there though any shaders I could use to deal with this?

PARTNERS