I am currently working in an RTS game in C++.
I read in alot of place that calling something "Manager" is generally bad, because it's too generic and say nothing about what the class really does.
However, i have no idea how to call them instead. Currently i have these:
- ImageManager: It load the images, and every class that need a texture can get it from this class. This is because IO operations are REALLY expensives, so i rather read the images once and use all from the memory.
- Building and Unit Manager: These classes have a container, which contains all Building/Unit which are currently alive. You can update them through this class and it's also check if you clicked to one of them.
- EventManager: I didn't wrote it yet, but this supposed to handle Commands and other events. You can basically post any command or event to execute them in the next iteration of event loop.
Any idea what name would fit better what these classes do?
Thank you very much for the answer!