Jump to content

  • Log In with Google      Sign In   
  • Create Account

gwihlidal

Member Since 23 Apr 2003
Offline Last Active Nov 09 2014 04:23 AM

Topics I've Started

Announcement: Game Engine Toolset Development

30 January 2006 - 08:49 AM

Hi everyone, I wanted to wait a bit before posting here in the hopes that this doesn't classify as "cross-posting" :) I just want to bring your attention to my first book, which will be available in early March (just in time for GDC!) Instead of creating a duplicate thread here, please visit this thread. Thank you for your time! ~Graham

[.net] Announcement: Game Engine Toolset Development

27 January 2006 - 05:22 AM

Hi everyone! Just wanted to unofficially announce my new book that is just about in publication. Game Engine Toolset Development will hit printers around February 14th, and should be in circulation around March 14th, just in time for GDC 2006! (By the way, I’ll be there if anyone wants to meet up). Instead of posting a whole bunch of info on the book, I’ll just give you a link to this site: http://www.getdbook.com The book is about building reusable and robust game engine tools using C# .NET 2.0. In case you see any posts on Amazon or other book sites, the current information on there is extremely old, so please visit the site I linked to above to get the correct information on the book. Thanks, and please let me know what you think! ~Graham

Do I need a valid Direct3D device to release associated resources?

05 July 2004 - 03:21 PM

Hi everyone, I am having some crashing issues with my engine when I shut everything down. It worked fine for the longest time, but either a leak was small enough to pass unnoticed, or I did something Direct3D didn't like. I noticed at one point sometimes I call release on a couple resources like textures and shaders that are created using the currently active device, but when I step through the debugger the device has already been released. Does this matter? Can I release resources even after the device itself has been released? It isn't a rendering issue, as that works fine, and I have traced and stepped through all my allocations MANY times. Thank you for your time, ~Graham

PARTNERS