Jump to content
  • Advertisement
Sign in to follow this  
  • entries
    61
  • comments
    131
  • views
    32232

HAH!

Sign in to follow this  
Samsonite

212 views

I have an AI DEMO in store for you!

Basicly all you can do is navigate your ship around and the AI will do stuff.

Oh, and there's no shooting, alas no blood - sorry!

Read the notes.txt for more info [smile].

Thank you very very very much for testing it out and giving me feedback. I have worked a week to fix a bug which was all about a .bmp being 16-bit instead of 24 [grin], so some feeback would be nice [smile].

Thanks again!

ExtraTerrestrial Invasion AI Demo

Sign in to follow this  


6 Comments


Recommended Comments

I couldn't move at all (it was running REALLY slow.)

My system info is:
Windows XP Home
DirectX 9.0c
3GB DDR400 RAM
ATI x700 PRO (256MB)
2.01GHz AMD Athlon64
(I don't know what version OpenGL)

Share this comment


Link to comment
Ran pretty fast on mine, like about .5 seconds to get across the screen, horizontally:

AMD AthlonXP 3000+
1GB Ram
Radeon 9700 Pro

Also, my ship showed up fine, but the aliens are just white boxes (big on top, small on side), is that not supposed to be that way?


They followed me around just fine though :)

Share this comment


Link to comment
It ran fine on my machine. The aliens showed up properly, and it took about 4-5 seconds to go top-to-bottom, left-to-right.

My system:
Athlon 2800
GeForce6600 GT
WinXP

Share this comment


Link to comment
The alien ships didn't display, but the player ship did.

One issue that you're going to hit - you're using SDL with a massive window. SDL's main drawback is that it is very fill-rate limited, since it's going to fully blit each draw call (including clearing the screen with transparent black, and excluding those calls which are outside the surface area). With a window the size you're using, its going to get really slow really fast. I'd highly recommend downsizing to 640x480 or so, though I've heard using a dirty rect system can also help a lot.

I decided to switch over to OpenGL :P

Share this comment


Link to comment
Wohooo, 4 testers [smile].

I run on a system similiar to takingsometime. So that might explain why I haven't noticed those slowdowns/rendering issues.

I have no clue whatsoever as to why the alien ships isn't rendering[sad]. The .5 second movement issue is because I haven't implemented FPS limiter yet, that would be done as soon as I get the time. Can you post the log.html file here? Maybe something is going wrong, I don't know...[sad].

Thanks for testing it out [smile]

EDIT: Mushu: I'm already using OpenGL for rendering, but SDL for window and input [smile].

Share this comment


Link to comment
I forgot to mention that everything rendered fine for me except for maybe the entity all the way to the right. It seemed like it was tiling about 1.5 times height-wise.

Share this comment


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!