• entries
    740
  • comments
    957
  • views
    730101

All Synced Up - More Blitz Blox Progress

Sign in to follow this  
Gaiiden

95 views

Friday, Dec 15

On Networking

Ok so I spent my entire time last night working on bringing all of my various web presences up to date. Networking is a very, very important aspect in this field, and so in order to achieve the greatest amount of permeation, you really do have to try and be everywhere so you can meet with the most people. Through your various networks of contacts is where you'll get all your support and opportunities.

So as I said, I updated all my various profiles. Here's the full list

You look at that list and you ask yourself - "isn't that a bit overkill?" the answer is no. There certainly comes a point, but the list above doesn't reach it... yet. The reason is that you can go to the site of each profile and find enough unique people to that site. It's not like I'm hanging with the same crowd everywhere I go. There are overlaps in some cases, but not enough for you to say you have the same contacts through one site that you do through another.

In addition to the profiles, I also updated the BES forums and BES website. I actually had two people spamming my forums, can you imagine that? I get like no traffic there (currently) - who would bother? Stupid ad bots. I also created project pages on GG for Blitz Blox and Galaxy Conquest, as well as updating my BES page on GG too.

I'm pretty enthused too about the whole GGE project (see badges in header), that seems like it will become quite the valuable network resource as it continues to grow and improve, I'm glad I've had the opportunity to get in on it early. If anyone else is interested and isn't a GG user, let me know and I'll send you a beta invite!

Don't be an introvert. Get out there and meet people. You'll be better for it. Trust me.



On Blitz Blox

So I finally was able to get some more programming done on Blitz Blox, which made me happy. I'm kinda annoyed that I don't have block interactions going yet, but everything I've been working on instead this week has been for good purpose, so it's not like I feel I've wasted time or anything. Today I just did a few simple things I knew I could bang out quick and get out of the way to further clear the path to get started on the actual game code.



This is the new game setup menu. I did some hacking in Paint.NET and added a new slot at the top so that the player can switch between the two game modes. I figured I might as well do this for the menu since I had to put it in the code anyways in order to properly set up the game code architecture.



TGB is so awesome. It took me all of 15 minutes to work out the code and routine that would pause the game. In the most basic sense it was firing up the level builder and creating the pause banner image, centering it on the screen then exiting to my code editor. There I created a function gamePause() and inserted three lines:

$isGamePaused = !$isGamePaused;
bbSceneGraph.setPause($isGamePaused);
pauseBanner.setVisible($isGamePaused);

and presto!! The game toggles between active and paused states. When you pause a scene graph, everything stops - which means the animations stop playing, particles stop effecting, and all movement is halted. I say again. TGB is awesome.



Finally, I added a few lines of code to the already-created audio settings menu to create the above image. The code was already there to show the game music track selection when this menu was called up during a game, I had to add in code to pause the game when the menu is brought up.

I also cleared out a few minor bugs... all except for one. This one has me utterly stumped too. In a repost from the GG TGB forums...
Quote:

I've come across a weird... bug? I'm not sure so before I post about it in the Bugs forum I want to try here first. Here is the code in question

echo($pref::Audio::channelVolume2);
if ($pref::Audio::channelVolume2 < 0.9)
echo("true!");

here is the console output

0.9
True!

How is this possible?? Hazel mentioned in #tgb that maybe the value of $pref::Audio::channelVolume2 is actually 0.89999 or something, but I can't see then why echo() would spit out 0.9.

So I was like "okay, that's weird" and decided to try doing it another way

echo($pref::Audio::channelVolume2);
if ($pref::Audio::channelVolume2 <= 0.8)
echo("true!");

Again, it failed - as evidenced by the console output

0.9
0.8 <= should have been true after this!
0.7
True!

Can anyone explain this? I'm at a loss here. Thanks in advance!!

Yea so that still fetters me.



In Closing

Cool, long entry. Well I did have to make up for yesterday after all :P *sigh* it's already 4am? I was hoping to get in some sort of game time - it is the weekend after all (peh! who am I kidding??). Ah well, I'll squeeze in an hour or two

Nite.
Sign in to follow this  


0 Comments


Recommended Comments

There are no comments to display.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now