• entries
    422
  • comments
    1540
  • views
    488530

Drivers are my nemesis

Sign in to follow this  
jollyjeffers

124 views

I hate Windows Vista
I hate Nvidia
(I retract the above temporary frustration [smile])

Had to detach my damned motherboard to get my 8800 in - I'm sure its bigger than the bricks used to build my house!!

Downloaded the latest 8800 drivers from Nvidia but Windows Vista is not Windows XP and everything comes crashing down. Grr.
Sign in to follow this  


19 Comments


Recommended Comments

Right, so I somehow beat Vista into submission and got it to recognise the hardware as an 8800GTS.

Best part is it BSOD's on ANY attempt at using it - D3D9 samples in the SDK die a horrible death.

Luckily I can get back to 1600x1200 and run the D3D10 RefRast for now. Still hate Nvidia for not releasing good drivers [flaming]

Share this comment


Link to comment
Oh wait, hold that... Running the D3D10 refrast locks up the system completely. Scratch the idea of doing ANYTHING with or even slightly related to this rather expensive lump of junk I just paid good money for.

GRRR.

Share this comment


Link to comment
hah, not Vista - I didn't pay anything for that [razz]. The £262-worth of GeForce 8800 that is currently occupying vast quantities of space inside my case yet doing a worse job than the miniscule 7300LE that it replaced [headshake]

My experiences with ATI have, in general, been better than Nvidia - but that could just be because I haven't used OpenGL [lol]

Cheers,
Jack

Share this comment


Link to comment
Quote:
Original post by jollyjeffers
I hate Windows Vista


Can we quote you on that Mr MVP? [smile]

I guess it's just silly to ask what OpenGL version the drivers support...

Seriously though, I know it's really frustrating when new kit doesn't work. Best of luck with it.

Share this comment


Link to comment
I guess it's kinda relevent, but I just got a 8800 also, and it works great under XP [grin]

Are you running 2 OSes? I guess when Vista comes out later this month I'll duel boot my system...

Are you using Vista RC2?

Share this comment


Link to comment
I guess it's kinda relevent, but I just got a 8800 also, and it works great under XP [grin]

Are you running 2 OSes? I guess when Vista comes out later this month I'll duel boot my system...

Are you using Vista RC2?

Share this comment


Link to comment
The 8800 should support GL 2.1, the extensions are already in the ARB so you should be able to use the DX10 extensions under OGL under XP [grin].

And, yes, I hate the fuck out of ATI's OpenGL drivers. I wish whoever wrote their FBO code would be sodomized by a nine-foot long chunk of rusty barbed wire fence coated in iron filings and gasoline.

Share this comment


Link to comment
What type of power supply do you have? That behavior would happen if your system was underpowered or your PSU had weak or fluctuating rails.

Share this comment


Link to comment
What type of power supply do you have? That behavior would happen if your system was underpowered or your PSU had weak or fluctuating rails.

Share this comment


Link to comment
Quote:
Can we quote you on that Mr MVP?
Looks like you already did! [oh]

Quote:
I just got a 8800 also, and it works great under XP
No fair [sad]

Quote:
Are you running 2 OSes? I guess when Vista comes out later this month I'll duel boot my system...

Are you using Vista RC2?
No, I'm using Windows Vista Ultimate RTM on my test machine and have XP-SP2 on my older main machine. No dual booting and no beta's...

Quote:
I wish whoever wrote their FBO code would be sodomized by a nine-foot long chunk of rusty barbed wire fence coated in iron filings and gasoline.
I'm sure a few ATI/AMD employees lurk around here, maybe you can call in a few favours... [wink]

Jack

Share this comment


Link to comment
Quote:
What type of power supply do you have? That behavior would happen if your system was underpowered or your PSU had weak or fluctuating rails.
A generic 420w PSU, so yes - rubbish quality AND below-spec. I was hoping I might just get away with it...

But you could well be right. I blamed the drivers simply because they were so hard to install - figured the BSOD's were due to a badly installed set of slightly incorrect drivers...

Maybe time to buy a new PSU as well.

Cheers,
Jack

Share this comment


Link to comment
Quote:
A generic 420w PSU, so yes - rubbish quality AND below-spec. I was hoping I might just get away with it...

I would honestly blame the PSU because it happened to a buddy just last weekend. When I built my new system I spent 150CDN on a PSU that was 700W with rails that are dead on spec just because I wanted to make sure I have enough power for awhile. My buddy decided he wanted to recycle his generic 450W PSU with his new system last week, but unfortunately it did the very same thing. You could boot the system and use the video card (8800GTX btw) but if you tried to use anything 3D it wouldn't work. We went out and bought him an Antec 500W for about 80 bucks I believe and it now works like a charm.

Share this comment


Link to comment
I'd rate you up for the advice if I could [grin]

My older main machine has a high-end Antec 350w PSU - it supports 4 HDD's, 2 optical drives, a Pentium 4, lots of USB AND a GeForce 6800 [oh]

Much like your justification I bought the better PSU specifically.. but for my newer machine I was hoping I could get away with "recyling" the one it came with [headshake]

Hiper 580W Type-R Modular PSU SLI/CrossFire Certified - Blue for £57.60 looks promising. Might buy one tomorrow...

Cheers,
Jack

Share this comment


Link to comment
Why hate Vista? They're not the ones who develop the drivers :P

I'm rather content with my 6800 for now until DX10 cards become more reasonably priced for college students.

Share this comment


Link to comment
Quote:
Why hate Vista? They're not the ones who develop the drivers :P
Very true - consider it more a case of venting general frustration [smile]

Quote:
I'm rather content with my 6800 for now until DX10 cards become more reasonably priced for college students.
Including this new PSU I'm getting it'll make an 8800 GTS cost around £340. Even on a decent salary such as mine that aint particularly cheap!!

But I have February to write ALL of the code for my section of the book and I'd rather not have to use the RefRast!

Quote:
You know my machine died a month ago? That was a Hiper PSU giving up the ghost.
Thanks for the heads-up. I was reading some reviews - those PSU's get 40-50 5-star reviews, but I have seen several mentions of them unexplainably going bang...

Guess I need to do some research [oh]

Cheers,
Jack

Share this comment


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now