"What naming convention (excluding notation) do you use for classes, functions, variables, etc?"
My query: does anyone exclusively use the same naming convention for classes, functions and variables?
Me? These days I use CamelCase for classes and lowerFirst for variables. Sometimes I fall back into my old habit of using under_scores for variables instead. These days I'm also using CamelCase for functions, but I used to use lowerCase for them (sometimes with under_scores with variables). And I often do prefixes with undercores too, such as labelling private variables as "my_variableName", mixing under_scores with lowerFirst.
I thought most people mixed it up a little, especially between variables and classes/functions.
(P.S. I'm still alive and doing stuff. I'm finishing up the last bit of business for the year, then hoping to dive into refreshing my programming skills within a week. I'll be posting more journal entries and forum questions then.)