Sign in to follow this  
  • entries
    42
  • comments
    85
  • views
    46490

Demo

Sign in to follow this  

255 views

Ok, I finally uploaded the demo! I also have a new name that's much more fitting for me. Thank you Drew!

Demo (win32)

EDIT:
Demo 2

If you want to fly, just hop on one of the green guys and start shooting them. Stickybombs ('n' key) are the best for keeping them away from you. There's an elusive bug involving the stickybomb, so be warned. I've been experimenting with a slow-mode, just hold down the spacebar! You can jump really high while in slow-mode, but it works fairly well despite some inconsistencies.

I have everything load from the resource files now, not just images and sounds. Just try and steal them now! :) I'm not actually worried about having my mediocre assets stolen, but I'm glad I know how to pack things into a resource file now. I've learned some important lessons about using iostreams and stringstreams instead of the stdio methods. It took a few heap corruptions before I really dug in and fixed my old ways.

I'm aware of the goofy animation that happens when you run and dash at the same time. I haven't touched the player control code in a long time. After I finalize the basic character movement (with the physics), the animations will be tight, and blend together nicely. I'm going to change the look of the character, and everything else for that matter. A concept silohuette is on the main menu. The menu background color will randomize every execution (seeded with a value in stat.xml based on the number of executions).

I haven't fixed a few issues with the tools, and they don't use the resource files, so they might blow up on you. Its best to avoid them for now.
Sign in to follow this  


5 Comments


Recommended Comments

I get a crash here too. The last thing the log reports is the GLEW version, but no errors. I'm on WinXP.

Share this comment


Link to comment
I've uploaded it again. I think it was a heap corruption because I didn't null-terminate the shader string after loading from the resource file. If it still doesn't work, I'll probably start a thread on deployment and beg for help.

Let me know if it works?

Share this comment


Link to comment
I'm getting the 'ol, "Windows needs to close this program" jazz on XP upon launch. Like the above poster, the log's last line is the GLEW info.

Share this comment


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now