• Advertisement
Sign in to follow this  
  • entries
    19
  • comments
    27
  • views
    21461

Technically... a demo is written... errr....

Sign in to follow this  

434 views

[BLURB]: Viewports and camera and demos... OH MY! Ummm... but demo doesn't work yet... lol!

[DEVELOPMENT: Archetype Engine]

Nothing major to talk about this blog, but I felt I should keep anyone who's still watching this journal apprised... I not have a "viewport" class that handles viewport setup for rendering. It does a little more than simply opening a view port. It can be configured to use "relative" positioning and sizing, and handles the "VIDEORESIZE" event. As such, one can create a viewport that should appropriately adapt it's dimentions and, even position relative to a resized window. Note that I said position... multiple viewports are supported and can be placed in "relative" locations using a 0.0% to 100.0% location scale. Also, position can be based on the center of a viewport.

Of course, that all sounds spiffy, but the one demo I have written now shows a blank, empty blackness (no, it's not suppose to be blank). Therefore, bugs are still abound in my code. However, seeing as I've been writing everything into the library without time to test each unit (horrible of me, I know), I'm actually happy I was able to get a runnable demo at all... yes, it's runnable. A window of the correct dimensions appears and when you press the escape key it closes, as it should. I just need to figure out why my camera wire frames aren't appearing. Ahhh well. Next couple of days I should know.

[PERSONAL DREK]

Just want to thank anyone still reading. Long way to go in general.
Sign in to follow this  


3 Comments


Recommended Comments

[quote][color=#1C2837][size=2]Of course, that all sounds spiffy, but the one demo I have written now shows a blank, empty blackness (no, it's not suppose to be blank).[/size][/color][/quote]

Aww, we don't even get a screenshot?

Share this comment


Link to comment
:) Hey Bossy... don't worry, I'm still hacking away at the engine!
Ezbez... just because you asked so nicely, I'll put one in my next post, whether it's showing something or not :D

Share this comment


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Advertisement