• Announcements

    • khawk

      Download the Game Design and Indie Game Marketing Freebook   07/19/17

      GameDev.net and CRC Press have teamed up to bring a free ebook of content curated from top titles published by CRC Press. The freebook, Practices of Game Design & Indie Game Marketing, includes chapters from The Art of Game Design: A Book of Lenses, A Practical Guide to Indie Game Marketing, and An Architectural Approach to Level Design. The GameDev.net FreeBook is relevant to game designers, developers, and those interested in learning more about the challenges in game development. We know game development can be a tough discipline and business, so we picked several chapters from CRC Press titles that we thought would be of interest to you, the GameDev.net audience, in your journey to design, develop, and market your next game. The free ebook is available through CRC Press by clicking here. The Curated Books The Art of Game Design: A Book of Lenses, Second Edition, by Jesse Schell Presents 100+ sets of questions, or different lenses, for viewing a game’s design, encompassing diverse fields such as psychology, architecture, music, film, software engineering, theme park design, mathematics, anthropology, and more. Written by one of the world's top game designers, this book describes the deepest and most fundamental principles of game design, demonstrating how tactics used in board, card, and athletic games also work in video games. It provides practical instruction on creating world-class games that will be played again and again. View it here. A Practical Guide to Indie Game Marketing, by Joel Dreskin Marketing is an essential but too frequently overlooked or minimized component of the release plan for indie games. A Practical Guide to Indie Game Marketing provides you with the tools needed to build visibility and sell your indie games. With special focus on those developers with small budgets and limited staff and resources, this book is packed with tangible recommendations and techniques that you can put to use immediately. As a seasoned professional of the indie game arena, author Joel Dreskin gives you insight into practical, real-world experiences of marketing numerous successful games and also provides stories of the failures. View it here. An Architectural Approach to Level Design This is one of the first books to integrate architectural and spatial design theory with the field of level design. The book presents architectural techniques and theories for level designers to use in their own work. It connects architecture and level design in different ways that address the practical elements of how designers construct space and the experiential elements of how and why humans interact with this space. Throughout the text, readers learn skills for spatial layout, evoking emotion through gamespaces, and creating better levels through architectural theory. View it here. Learn more and download the ebook by clicking here. Did you know? GameDev.net and CRC Press also recently teamed up to bring GDNet+ Members up to a 20% discount on all CRC Press books. Learn more about this and other benefits here.
  • entries
  • comments
  • views

On C++ Naming Conventions

Sign in to follow this  
Followers 0


I threw myself back into the deep end of C++ again a few months ago, having spent the last couple of years with an emphasis on C# and .NET.

One thing that I'm thinking of is the old subject of coding style. Every software house tends to have a house style, so at work you just adopt that - but at home, on personal projects I find myself drifting around stylistically, at least with naming conventions.

There's a few main styles that I tend to consider ok for me:

.NET Style
Microsoft have a standard set of style guides for .NET / C# programs which for the most part people adopt (although not always, even within Microsoft public code).

The .NET style is simple:

  • PascalCase for class names
  • PascalCase for public methods (all methods, in fact)
  • Interface classes start with an "I"
  • Public properties/variables are PascalCase
  • camelCase for variable names
  • Namespaces are PascalCase
  • Assembly Names are PascalCase

    Code would look something like this:namespace MyProject{ public interface IBar { } public class Foo : IBar { public void DoSomething(int parameterName); public int SomeProperty { get; set; } }}
    It's worth noting that the get/set property functions end up becoming something like "SomeProperty_get"/"SomeProperty_set" under the hood.

    Java Style

    Java programs also have a common style.

    • PascalCase for class names
    • Interface classes start with an "I" (but not always)
    • camellCase for public methods
    • Public properties/variables are camelCase, prefixed with getXX() or setXX() (as Java doesn't have properties)
    • camelCase for variable names
    • Namespaces are lowercase
    • Package Names are lowercase

      In Java, the above example looks something like:package myproject;public interface IBar { }public class Foo implements IBar{ public void doSomething(int parameterName); public int getSomeProperty(); public void setSomeProperty(int value);}
      C Style / C++ Standard Library Style

      C++ seems to have a tonne of styles. One of the first ones you'll come across is that of the standard library, which appears to have adopted the C style convention, largely due to remaining consistent with the old code from yesteryear.

      Here, we have:

      • lowercase_delimited for class names
      • Interface (abstract) classes aren't special
      • lowercase_delimited for public methods
      • Public properties/variables are lowercase_delimited, there doesn't seem to be a get/set style (?)
      • lowercase_delimitedfor variable names
      • Namespaces are lowercase

        Back to our example:namespace myproject{ class bar { public: virtual ~bar() { } }; class foo : public bar { public: void do_something(int parameter_name); int get_some_property(); void set_some_property(int value); };}
        Looking through some other sources and the Google C++ guide seem to lean to a blend of the Java Style with C++/Standard library style.


        • PascalCase for class names
        • Interface classes start with an "I" (but not always)
        • PamellCase for public methods
        • Public properties/variables are lowercase_delimited, prefixed with my_property() or set_my_property()
        • camelCase for variable names
        • Namespaces are lowercase_delimited

          This leads to:namespace my_project{ class Bar { public: virtual ~Bar() { } }; class Foo : public Bar { public: void DoSomething(int parameterName); int some_property(); void set_some_property(int value); };}
          With all this, the Google version seems to make a lot of sense.

          What's your style and how did you pick it?

Sign in to follow this  
Followers 0


I'd agree that using non-standard naming conventions for home projects is somehow incoherent, since you'll have to mix it up with coding standards of used libraries anyway. But I wouldn't call debating over that topic a waste of time in general, since it's a productivity related issue. On the other hand, there is a reason that modern languages do not use that lowercase-dashy style. For most of programmers I know camel/pascal case is way much easier to read and maintain, and for some of them it was one of the main reasons to use Java/C# and choose those as professional careers paths over C/C++.
I'd say: you choose your language, obey the rules. The unwritten ones aswell.


Share this comment

Link to comment
In my experience, there are very few cases in which interfaces are prefixed with "I" in Java, so I don't think it is the norm there. At least I've seen no such thing in the standard library (nor any other library I've used).
Months ago I started to prefix interfaces with "I" because I thought they were different enough from concrete classes and abstract classes to merit it. After a while I started to think that the whole purpose of interfaces is to keep the user from worrying about the internals. So my conclusion was that prefixing interfaces with "I" is counterproductive to their purpose.
The dedicated prefix singles them out as interfaces and prevents you from intuitively think of it as any other object. Probably there is a reason to single out interfaces when you're coding them or the supporting code around them, but for the user, their usage and "looks" should be indistinguishable from regular classes, or at least that's what I think.
I rely on what I consider less intrusive for distinguishing classes, abstract classes and interfaces by using different colors for them.
EDIT: I see lots of cane shaking here :D

Share this comment

Link to comment

Personally I don't like the "I" (hungarian notation?) notation, beside my own style rules, I have a big rule:


If something is occurring too often in class names, maybe is time for a new namespace (and that's how is born my Mesh namespace xD. of course there will never be a "I" namespace). That's it, I usually program by interfaces so almost everything in public API should be prefixed with I wich is not good, even in that case I still prefer a " 'Interfaces' namespace" rather than a big "I" in front of the name. Interface is about "how to use" an object, so it doesn't matter if it is pure virtual (IMHO).


Underscored names are in google style guide, but I think the real reason for them is that "_" names are easier to read for search engines (should we optimize our code also for search engines? O.o). I prefer PascalCase for classes, namespaces and functions. and camelCase for methods and member variables (widely adopted convention)


My style is not truly mine, in the mean that I found few girls in my classroom wich was writing really good-lookin code and I tried to figure out how to write it myself (newlines and indentation). I also asked permission for copying that style and immediatly I had a better code :D. Don't invent a style, just find one that you like and use it :D


Share this comment

Link to comment

One thing that is interesting is that sometimes at the start of a coding project it's not quite clear if you want a pure interface (eg: no data, no method implementations) or an abstract class, which contains some common cruft.


Obviously, you can start with an interface and then base an abstract class on it to be your base class for more specialized implementations, but that does seem to start getting a little nasty.


This case supports the comments about interfaces not starting with "I", so that's an interesting point you guys are making.


Share this comment

Link to comment

Whether it's an intent to write better code or just a severe case of obsessive compulsive disorder, i think programmers have made a big case of naming convertions just because we've been 'programmed' to always seek for the -best- possible solution. But terrifyningly, i think this subjects falls into one of those dreaded "it's-all-very-subjective" cases.


The way I adapted a naming convension was progressively looking at other people's source code, and one convension rule that they've used i'd like, and another one i'd hate. At one point, I looked at some big guys' source code for conventions myself, but I just didn't like all of em, some felt weird to me.


So through time, I'm now writing code like this:


  • PascalCase for class names
  • camellCase for all methods, properties, variable names
  • Namespaces, Package Names are lowercase
  • Interface classes start with an "I"
  • Abstract classes start with an "A"
  • Enums start with an "E"
  • constant names are all CAPS.
  • private methods, properties, variables, are prefixed with "__"
  • protected methods, properties, variables, are prefixed with "_"
  • function arguments are prefixed with "p_"
  • local variables are prefixed with "l_"
  • brackets take a line on their own and everything inside is indented forward one step


Random copy paste from some source code:

 * Main Display Service Class
 * @author Aris Kostakos
class Display extends AService implements IDisplay
	//@todo: Reflection needed here!!! See above todo
	//@think: this is a nice way to check if a new view/scene/entity/etc has been created.

	public var space( default, null ):IGameEntity;
	protected var _invalidated:Bool;
	public function setSpace(p_gameEntity:IGameEntity):IGameEntity
		//cast the gameEntity, and complain if space already set.
		if (space != null)
			//@note if another space already exists, maybe you can warn better the user, or take
				//other action. may need rerendering, changing renderers, etc, etc, etc
			Console.warn("A space object is already bound to the Display service! Rebounding...");

		space = p_gameEntity;

		return (space);

It works for me so I'm happy...


Share this comment

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now