• entries
    27
  • comments
    61
  • views
    12717

WOA V - Day 6

Sign in to follow this  
ArThor

700 views

Its the end of Day 6. Slow progress again. But the game just about works now. Its lacking a lot. Icons and sound are completely missing. I need to find fonts too. As well as creating the final assets and campaign. And thew whole things needs polishing too.

However, the loading and saving are much better implemented and the alien and tower data is pulled out into text files. Waves are implemented now and the game ends albeit by jarringly transferring back to the main menu if you run out of castle health,(I also need a castle geometry.). I'm sure their are a bunch of other issues and bugs too.

Map4.thumb.png.47c49dda6d0bb995831ff849172c1aff.png

There is a version available here: https://www.dropbox.com/s/hv2mctwui3zfgf3/WOA_V.zip?dl=0

It isn't complete but I would appreciate it if anyone (Especially anyone with an AMD gpu) can let me know if it doesn't run at all, which I am expecting! . Rename _DO_DEBUG.txt to DO_DEBUG.txt to switch to GPU debugging mode and get more info in the glDebug log file. All in the bin folder.

Instructions

Click Load Map from the game screen to load my test map.

Click Launch Waves to start the waves. Only two...

Click a tower foundation to see build options. Everything is 50 gold.

Sign in to follow this  


4 Comments


Recommended Comments

AMD Radeon HD 8500M user here.

I can't even start the game.

Look here a screenshot, maybe it'll help.

image.thumb.png.2f6f336b6fe94a2f6cc0bc905f6ea12d.png

 

If I enable DO_DEBUG.txt file. Nothing is printed there.

Edited by Kavarna

Share this comment


Link to comment

Game looks cool, I want to try it but as you suspected my AMD GPU is a blocker...

GPU is a Radeon HD 7700 series  (7790 maybe? I don't remember exactly, it's a few years old). My drivers are up-to-date though.

The application starts, displays dog&rocket logo and then onto the main menu which looks like this for me:

image.thumb.png.511b89f7a96219b229093dddade2041f.png

But then crashes when I click new game:

image.png.c923237ea38859ee141fbec3260d5cb9.png

 

When I enable the DO_DEBUG.txt file then the window is blank (no logo no main menu). This is the log I get:

DebugSourceApi DebugTypeError 3200 DebugSeverityHigh Using glTexImage2D in a Core context with parameter <components> and enum '0x1' which was removed from Core OpenGL (GL_INVALID_ENUM)
   at System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
   at System.Environment.get_StackTrace()
   at Framework.OpenGL4Window.Callback(DebugSource source, DebugType type, Int32 id, DebugSeverity severity, Int32 length, IntPtr message, IntPtr userParam)
   at OpenTK.Graphics.OpenGL4.GL.TexImage2D(TextureTarget target, Int32 level, PixelInternalFormat internalformat, Int32 width, Int32 height, Int32 border, PixelFormat format, PixelType type, IntPtr pixels)
   at Framework.Rendering.Textures.TextureResources.LoadTexture(Face face)
   at Framework.Framework.TextRendering.FTFontWrangler.Init(Face face)
   at Framework.FTFontSystem.GetFont(String path, UInt32 size)
   at Framework.States.FSPropertyListState..ctor(Application app, Int32 windowWidth, Int32 windowHeight, String title, String image, Sounds sounds)
   at WOA_V.States.SFBControlsMenuState..ctor(Application app, KeyMap keymap, Int32 windowWidth, Int32 windowHeight, String title, String image, Sounds sounds)
   at WOA_V.States.MasterState..ctor(WOA_V app)
   at WOA_V.WOA_V.ApplicationLogic(Object sender, FrameEventArgs e)
   at System.EventHandler`1.Invoke(Object sender, TEventArgs e)
   at OpenTK.GameWindow.OnRenderFrame(FrameEventArgs e)
   at Framework.OpenGL4Window.OnRenderFrame(FrameEventArgs e)
   at OpenTK.GameWindow.RaiseRenderFrame(Double elapsed, Double& timestamp)
   at OpenTK.GameWindow.DispatchUpdateAndRenderFrame(Object sender, EventArgs e)
   at OpenTK.GameWindow.Run(Double updates_per_second, Double frames_per_second)
   at Framework.Application.Run()
   at WOA_V.Program.Main(String[] args)
DebugSourceApi DebugTypeError 2267 DebugSeverityHigh glUniformMatrix4fv has failed because the operation requires a currently active program object (GL_INVALID_OPERATION)
   at System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
   at System.Environment.get_StackTrace()
   at Framework.OpenGL4Window.Callback(DebugSource source, DebugType type, Int32 id, DebugSeverity severity, Int32 length, IntPtr message, IntPtr userParam)
   at OpenTK.Graphics.OpenGL.GL.UniformMatrix4(Int32 location, Int32 count, Boolean transpose, Single* value)
   at OpenTK.Graphics.OpenGL.GL.UniformMatrix4(Int32 location, Boolean transpose, Matrix4& matrix)
   at Framework.Rendering.Shaders.FTTextShader.SetTransform(Matrix4 mtx)
   at Framework.SquidGUI.SquidUIRenderer.DoDraw(Int32 width, Int32 height)
   at Framework.SquidGUI.SquidRenderPath.Render(Double interpolation)
   at Framework.OpenGL4Window.OnRenderFrame(FrameEventArgs e)
   at OpenTK.GameWindow.RaiseRenderFrame(Double elapsed, Double& timestamp)
   at OpenTK.GameWindow.DispatchUpdateAndRenderFrame(Object sender, EventArgs e)
   at OpenTK.GameWindow.Run(Double updates_per_second, Double frames_per_second)
   at Framework.Application.Run()
   at WOA_V.Program.Main(String[] args)

 

Edited by dmatter

Share this comment


Link to comment

have an amd r290 here, same issue as dmatter.  can load upto menu, then same error message.

 

going into common/shaders/shadowmap and removing the varying keyword before in in both ShadowMap_Frg.glsl and AnimShadowMap_Frg.glsl fixed the issue.

 

In game launch waves doesn't seem to do anything.

Share this comment


Link to comment
11 hours ago, Kavarna said:

AMD Radeon HD 8500M user here.

I can't even start the game.

Look here a screenshot, maybe it'll help.

image.thumb.png.2f6f336b6fe94a2f6cc0bc905f6ea12d.png

 

If I DO_DEBUG.txt file. Nothing is printed there.

 

11 hours ago, dmatter said:

Game looks cool, I want to try it but as you suspected my AMD GPU is a blocker...

GPU is a Radeon HD 7700 series  (7790 maybe? I don't remember exactly, it's a few years old). My drivers are up-to-date though.

The application starts, displays dog&rocket logo and then onto the main menu which looks like this for me:

image.thumb.png.511b89f7a96219b229093dddade2041f.png

But then crashes when I click new game:

image.png.c923237ea38859ee141fbec3260d5cb9.png

 

When I enable the DO_DEBUG.txt file then the window is blank (no logo no main menu). This is the log I get:


DebugSourceApi DebugTypeError 3200 DebugSeverityHigh Using glTexImage2D in a Core context with parameter <components> and enum '0x1' which was removed from Core OpenGL (GL_INVALID_ENUM)
   at System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
   at System.Environment.get_StackTrace()
   at Framework.OpenGL4Window.Callback(DebugSource source, DebugType type, Int32 id, DebugSeverity severity, Int32 length, IntPtr message, IntPtr userParam)
   at OpenTK.Graphics.OpenGL4.GL.TexImage2D(TextureTarget target, Int32 level, PixelInternalFormat internalformat, Int32 width, Int32 height, Int32 border, PixelFormat format, PixelType type, IntPtr pixels)
   at Framework.Rendering.Textures.TextureResources.LoadTexture(Face face)
   at Framework.Framework.TextRendering.FTFontWrangler.Init(Face face)
   at Framework.FTFontSystem.GetFont(String path, UInt32 size)
   at Framework.States.FSPropertyListState..ctor(Application app, Int32 windowWidth, Int32 windowHeight, String title, String image, Sounds sounds)
   at WOA_V.States.SFBControlsMenuState..ctor(Application app, KeyMap keymap, Int32 windowWidth, Int32 windowHeight, String title, String image, Sounds sounds)
   at WOA_V.States.MasterState..ctor(WOA_V app)
   at WOA_V.WOA_V.ApplicationLogic(Object sender, FrameEventArgs e)
   at System.EventHandler`1.Invoke(Object sender, TEventArgs e)
   at OpenTK.GameWindow.OnRenderFrame(FrameEventArgs e)
   at Framework.OpenGL4Window.OnRenderFrame(FrameEventArgs e)
   at OpenTK.GameWindow.RaiseRenderFrame(Double elapsed, Double& timestamp)
   at OpenTK.GameWindow.DispatchUpdateAndRenderFrame(Object sender, EventArgs e)
   at OpenTK.GameWindow.Run(Double updates_per_second, Double frames_per_second)
   at Framework.Application.Run()
   at WOA_V.Program.Main(String[] args)
DebugSourceApi DebugTypeError 2267 DebugSeverityHigh glUniformMatrix4fv has failed because the operation requires a currently active program object (GL_INVALID_OPERATION)
   at System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
   at System.Environment.get_StackTrace()
   at Framework.OpenGL4Window.Callback(DebugSource source, DebugType type, Int32 id, DebugSeverity severity, Int32 length, IntPtr message, IntPtr userParam)
   at OpenTK.Graphics.OpenGL.GL.UniformMatrix4(Int32 location, Int32 count, Boolean transpose, Single* value)
   at OpenTK.Graphics.OpenGL.GL.UniformMatrix4(Int32 location, Boolean transpose, Matrix4& matrix)
   at Framework.Rendering.Shaders.FTTextShader.SetTransform(Matrix4 mtx)
   at Framework.SquidGUI.SquidUIRenderer.DoDraw(Int32 width, Int32 height)
   at Framework.SquidGUI.SquidRenderPath.Render(Double interpolation)
   at Framework.OpenGL4Window.OnRenderFrame(FrameEventArgs e)
   at OpenTK.GameWindow.RaiseRenderFrame(Double elapsed, Double& timestamp)
   at OpenTK.GameWindow.DispatchUpdateAndRenderFrame(Object sender, EventArgs e)
   at OpenTK.GameWindow.Run(Double updates_per_second, Double frames_per_second)
   at Framework.Application.Run()
   at WOA_V.Program.Main(String[] args)

 

 

10 hours ago, slicer4ever said:

have an amd r290 here, same issue as dmatter.  can load upto menu, then same error message.

 

going into common/shaders/shadowmap and removing the varying keyword before in in both ShadowMap_Frg.glsl and AnimShadowMap_Frg.glsl fixed the issue.

 

In game launch waves doesn't seem to do anything.

Thanks for the feedback guys its really helpful. I'll look into those issues. Yours might be a tough one though Kavarna.

Share this comment


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now