• Advertisement
Sign in to follow this  
  • entries
    108
  • comments
    319
  • views
    137856

Fixed

Sign in to follow this  

316 views

I fixed the bug that was popping up on exit as well as put in some midi files. The problem had to do with one of the loops that I didn't start up correctly. As for the particles disappearing, that was my attempt at dynamically seeing if it needed the downgraded graphics (bad idea), I'll make an in-game options menu eventually.

Next on the menu are sound effects, ship explosions, lives, level transitions, saved config file... I'm still very open for ideas and suggestions. I still haven't really used Lua for anything....

Random Interest


PsychoPong
I only got to level 4
Sign in to follow this  


7 Comments


Recommended Comments

Add enemy ships that come and try to pwn you. Those are always fun, and will give you a chance to play around with AI [wink]

Share this comment


Link to comment
Quote:
Add enemy ships that come and try to pwn you. Those are always fun, and will give you a chance to play around with AI
Good idea. That'll also give me a reason to use Lua [smile].

As for the music, I put in the first midi file I found; Don't blame me!!!

Share this comment


Link to comment
Hey, that's ace! [cool]

One question though. You're using PNGs, so why not use full alpha transparency on your sprites, rather than colour-keyed?

Share this comment


Link to comment
Too lazy to get that into the engine.... All I want to do right now is finish off the engine and the game and then move onto something else. As far as I know, using the alpha channel in the PNGs will work, I haven't tried. You could try it if you want [smile].

Share this comment


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Advertisement